Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My GTA IV version is 1.0.7.0 and I am trying to enable anti-aliasing but I am unable to find a setting in the game to do this. The image preview below looks fine but if you click on the image and see its bigger size, you can see clear aliasing.

Screenshot of GTA4
Click image preview above to view higher-resolution, original-sized image.

My graphics card is a GTX560ti and I am trying to force anti-aliasing within the nVidia Control Panel but it's not taking effect.

How can I force anti-aliasing for Grand Theft Auto IV?

share|improve this question
    
I don't know about NVIDIA, but there's a program that AMD/ATI uses called Catalyst Control Center that allows you to closely manage your graphics card. If NVIDIA has a program like that, you could use it to force AA. –  Aceofgods Apr 18 '12 at 0:06
    
@ks0830: At what settings are you running the game ? –  GTX OC Apr 18 '12 at 7:44
    
Video Mode : 1928 x 1080 (60Hz) Texture Quality : High Reflection Resolution : Very High Water Quality : Very High Shadow Quality : High Night Shadows : High Texture Filter Quality : Anisotropic x16 View Distance : 100 Detail Distance : 100 Vehicle Density : 100 Definition : On VSync : On AND ALSO SMAA-ULTRA!!!!!!! –  4545454545SI Apr 18 '12 at 10:32
    
Did your game take a performance hit after applying AA ? –  GTX OC Apr 18 '12 at 11:10
1  
little. before, FPS was 34~55, avg was 45. now 29~54 avg is 38. little change. –  4545454545SI Apr 18 '12 at 11:30
add comment

3 Answers

up vote 4 down vote accepted

AFAIK, the driver software for both Nvidia and AMD/ATI can't force AA in GTA IV due to how GTA IV's graphics engine was made (or rather, how it was ported to the PC from the console platform).

You can however, force SMAA on it by using injectSMAA:

Description:

  • adds "Subpixel Morphological Antialiasing" to an application
  • is based on "injectFXAA" (written by "some dude")
  • is supposed to work only with directx 9, directx 10, directx 11, x86 applications
  • may be incompatible with any other form of antialiasing
  • may be incompatible with overlays (Steam Overlay, MSI Afterburner, Fraps, ...)

SMAA is a very efficient GPU-based MLAA implementation, capable of handling subpixel features seamlessly, and featuring an advanced pattern detection & handling mechanism.

http://www.iryoku.com/smaa/

Screenshots (from http://mrhaandi.blogspot.com/p/injectsmaa.html):

Click image previews below to view higher-resolution, original-sized image.
No AA:
No AA

With SMAA:
With SMAA

share|improve this answer
1  
HAHA Thats more like it! I really appreciate! Thank you!! –  4545454545SI Apr 18 '12 at 10:27
add comment

Forcing AA in Nvidia control panel doesn't work. The FXAA option should reduce aliasing and soften the image (textures get blurred) and isn't perfomance-heavy.

I've looked into this myself and the only methods of AA i discovered are.

  1. FXAA in control panel
  2. inject SMAA (as above)
  3. SweetFX (google it, don't use with enb)
share|improve this answer
add comment

You can also use the nVidia Control Panel.

Under Manage 3D Settings, select the GTA IV profile or create a new one (for the GTA 4 executable). Then put Anti-aliasing FXAA "ON" and apply. You might also have to switch Anti-aliasing control to "enhance the application setting" and select what level AA you want (ie 4x).

share|improve this answer
1  
Not sure myself (as I do not use a nVidia card) but the accepted answer seems to indicate that this won't work - have you been able to test this? –  kalina Jun 26 '12 at 1:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.