Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have read through a couple of these forums discussing lag issues with W2; all of which seem to be running of questionable systems performance wise.

My rig is running:
Windows 7
16GB RAM
2600K-i7 Overclock :4.6Ghz 
GeForce GTX 560 Ti in SLI x2 (2GB each)
Acer GD235HZbid Widescreen 23.6" 3D LCD Display(three of these)
ASUS P8Z68 Deluxe MB

Id like to also say that I only run this game on one screen; not spanned across three.

I would consider my computer high-end and this game is defiantly not new. Whats really strange is that I don't really notice a performance difference between when I have the game running on one video card or both! So its seems that the obvious answer is that the graphics engine this game rolls with is horrible. So what element or combination of elements in the graphics engine are recipe for this choppy heart ache. From what I have played so far the game is loads of fun; but this lag is ruining my experience. ALSO NOTE: I have the latest drivers from nvidia and the most recent update for this game. Any insight as to what the spec issues are here would be greatly appreciated! I am really interested in why this graphics engine is such a flop and what aspects made it this way. Thanks for reading my post and thanks for any help you can present to this issue!

share|improve this question
    
its a rather badly optimized game in general. my machine is no where near as good as yours, but it should be able to run the game fairly well but I still have to turn down a lot of stuff I normally don't have to for other games. –  z ' Apr 19 '12 at 17:12
1  
Runs quite smoothly for me, my system is similar to yours just more ram. Your situation sounds like a driver problem, can you try older drivers? Also it could be something as simple as vsync messing it up, or another setting interfering. –  Viper_Sb Apr 19 '12 at 17:24
    
Thank you Viper Ill try can I ask your frame rate and your graphics settings? Perhaps if I match yours I can pinpoint my issue? –  Wylie Coyote SG. Apr 19 '12 at 17:58
    
check video drivers(try out the latest beta drivers first)/fragmentation of drive(if mechanical drive)/fragmentation of game(if ran through steam) I also usually turn off vsync –  Brent Hacker Apr 19 '12 at 19:32
    
Thanks Brent! Ill give the beta drivers a try; I also have yet to try the vsync option! something I will be doing later tonight! –  Wylie Coyote SG. Apr 19 '12 at 19:42
add comment

2 Answers 2

up vote 4 down vote accepted

Witcher 2 is not optimized as it should be by default,then the new crossfire/SLI technology is known to make performance issues simply by bugging drivers/game engine especially in older games.

So having up to date drivers and game is a must.

Other than you are left only with tweaking the user.ini file in witcher and making it read-only.

Here are the values and more information.

share|improve this answer
    
Outstanding! I had my suspicions; but we so many variables I figured asking the community already had the research done. *Thanks for your time! * –  Wylie Coyote SG. Apr 19 '12 at 21:26
add comment

Maybe you have the DRM version of the game. DRM makes the game lag. If you got the game legally (through retail buying or online), you can go to www.gog.com and there you can download for free a DRM Free version of the game. Check it out and let me know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.