Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

This I'm sure has been asked before, but has anyone ever figured out what causes Objects (IE Bookshelves and Clutter) to literally fly across the room like an explosion happened? This seems to be extremely prevalent with bookshelves especially?

Is this an FPS problem? I noticed a lot of people (myself included) have Physics Bugs with FPS's above 60 (mine hits 120 and I'll start hearing splashing sounds/character acts like he's swimming).

Is there a fix?

share|improve this question
3  
If you're sure it's been asked before, did you search for the question on this site? –  skovacs1 Apr 25 '12 at 13:36
    
No worries. I just checked. It hasn't been asked here yet. –  skovacs1 Apr 25 '12 at 13:48
1  
Searching isn't as easy as it sounds (without going through pages of stuff)/ –  Mercfh Apr 25 '12 at 14:32
    
I was half poking fun and half seriously trying to save having to search for it myself. –  skovacs1 Apr 25 '12 at 15:18
    
Great question - as I randomly get owned by flying cheese. I always wondered why. Save Often!! (also, +1) –  Zero Stack Apr 25 '12 at 15:41
show 1 more comment

2 Answers

up vote 5 down vote accepted

Yes it is an FPS problem and yes, there is a fix - limiting your FPS. Several sites will direct you to information such as this which will corroborate that this is caused by the FPS. It's prevalent with any small objects and even small animals. The swimming is likely because someone's physics mesh has passed through something else and they think that they are swimming. Reducing FPS should resolve this issue as the objects and their physics meshes should be more in sync when their positions and collisions are calculated - there's probably more to it than that, but this covers the general idea of why your world seems to be exploding at the opening of a door.

share|improve this answer
    
Oh wow that video made me laugh so hard ahaha. –  Mercfh Apr 25 '12 at 14:32
    
Oh damn you electronics. The Skyrim VSync does not allow my fps to go beyond my monitor's refresh rate. 60 Hz, so 60 fps. Hope to get a good monitor someday to see such effects. Sounds like fun. –  ヴァイシャリ Apr 25 '12 at 17:16
add comment

The PC Gaming Wiki, "Skyrim" article states that "Disabling V-sync is HIGHLY UNRECOMMENDED. It introduces bugs with physics, time-scaling, graphics and controls", with this Bethesda forums post, "Do NOT disable vSync!" as its source:

The number one "fix" on this forum for Skyrim is to disable vSync through the "iPresentInterval = 0" tweak in the INI file. However over the last week or so it's come to many people's attention that disabling vSync this way causes all manner of bugs and glitches.

Notice that even if you force vSync through your GPU's control panel, Radeon Pro, DXD3Overrider etc, these bugs will still persist. The only way to stop them, unless noted otherwise, is to set iPresentInterval to 1.

Crazy Physics

Allowing your FPS to go over 60fps causes the physics engine to go a bit out of control. The slightest touch, even opening a door, can send pots and pans 10 foot away flying all over the place. Whilst this may seem funny, it can have disastrous consequences if a really important item flies so fast it gltches out of the playable area.

This can however be solved by limiting your FPS to 60.

Day and time out of sync

With iPresentInterval disabled, the time and day will gradually go out of sync. Shadows update correctly, shops close and open at the right time and the sun sets and rises correctly. However the physical day (for example Turdas) won't change until 5pm. This not only breaks immersion, but can also break some quests where the AI relies on the actual day changing.

NOTE: It has been confirmed that this will cause NPC schedules to go out of sync, and does break some quests.

This cannot be fixed with a FPS clamp, or by forcing vSync externally.

(there are also other issues with disabling Vsync mentioned in that forum post)

So, the solution is to enable Vsync internally:

  • Go to %USERPROFILE%\My Documents\My Games\Skyrim\
  • Open SkyrimPrefs.ini. Navigate to the [Display] section.
  • Set the entry iPresentInterval=0 to iPresentInterval=1
  • Save the file.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.