Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Unlike this guy, I can launch the Worms Reloaded demo from Steam on my Windows 7 64-bit machine just fine.

However, once I get into the demo, all the menus act as if I'm holding down the down arrow (or some similar key). I know this is not the case because I'm not touching either my keyboard or mouse, and according to other programs, no key events are being sent. I don't know if this has any effect once I start playing, because I could barely configure my team. Any help would be appreciated.

share|improve this question
add comment

4 Answers

Some hints:

  • Do you have a joypad connected? Disconnect it and retry

or

  • This behavior happens also to me sometimes in full game (not demo) when I am pressing some keys during load times. It seems like the keys queue is not cleared. So be sure to not press any keys during menu and game loading.
share|improve this answer
    
I have an XBox 360 wireless controller receiver, but none of my controllers were paired at the time, and have since disconnected it for another purpose. I'm pretty sure I wasn't holding down any keys when I started the game, and since it happens every time, it doesn't seem likely to be the cause. –  MBraedley Sep 8 '10 at 0:47
add comment
up vote 1 down vote accepted

For some reason, it always starts up as if the down arrow is pressed. Pressing the down button a few times when the menu is up keeps it from cycling. Not a permanent fix, but at least it makes things usable.

share|improve this answer
add comment

Well that is strange. Some solutions:

1) Try running it in compatibility mode with another OS.

2) Unplug the keyboard to see if the behavior repeats itself, maybe Worms Reloaded doesn't like something about the Input device.

3) If you have a spare keyboard use it and see if the game has the same behavior.

4) If none of the above work try contacting Team17 support since clearly it's a weird bug.

share|improve this answer
    
1) from Steam, so compatibility mode is possible, but AFAIK, a little harder than normal. 2) Already tried that, as well as an alternate keyboard. 3) see (2) 4) Steam just downloaded a patch, so it may have fixed it for me, going to try in a bit. –  MBraedley Sep 8 '10 at 0:48
add comment

I had this issue and found a joystick emulator was to blame. This was being used to play Left 4 Dead 2 splitscreen on PC.

Using Steam on Windows XP SP3.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.