Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have been searching for an answer to the crash-to-desktop (CTD) issue for days since I first began playing. All I come across are 10-page-long discussions that appear to consist only of new members joining the forum just so they can chime in with, "This is happening to me, too!" The only thing anyone ever has to offer is a link to the same site I've seen a dozen times with a list of "common things that may help", but none ever do.

The CTD is random. I hardly ever know when it's going to happen, although, sometimes, I get into a spot in the game where the crash is consistent at around the same spot.

Among some of the things I've tried:

  • turned off AA
  • using low setting presets
  • playing windowed
  • turning off v-sync (even though this is just spitting in the face of my 480GTX)
  • 44.1 khz sound tweak

Many of these tweaks I tried only for peace of mind and would never play with them. For example, turning off AA or v-sync? No thanks, I'll take my smooth edges and jitter-free frame rates to another game.

There has to be something other than these compiled checklists of random tweaks that no one ever reports as 100% effective. Isn't there an official patch for this? Hasn't Bethesda addressed this? Hundreds upon hundreds of people are having this problem.

My specs -

Windows 7 32-bit 4 GB RAM Nvidia 480 GTX Intel i5 3.33 Ghz

share|improve this question
    
Do you have logmein or teamviewer installed? –  Zero Stack May 1 '12 at 23:05
    
nope. i do not. –  oscilatingcretin May 1 '12 at 23:09
1  
Any mods installed for Skyrim? –  mordi2k May 1 '12 at 23:40
1  
It happens to me also, in various situations, with a frequency of about 1 times per hour of play. IMHO there is not one bug only but various combination of bugs, memory occupation / leakage, etc. That's unfortunately how most Bethesda sandbox games works. Quick-save often, that's the only thing I can suggest. –  Drake May 2 '12 at 7:26
3  
Welcome to the would of Bethesda. –  ewanm89 May 2 '12 at 9:22

6 Answers 6

up vote 4 down vote accepted

Maybe your computer or graphics card is getting too hot. Check how long you can run Skyrim until it crashes.

Also, check this out -> http://skyrim.nexusmods.com/downloads/file.php?id=4192 I heard it does a very good job of preventing CTDs.

And save often!

share|improve this answer
    
I downloaded the file from your link, but the instructions do not explicitaly say where the files need to be extracted to. I found the SkyrimPrefs.ini file on my drive, so it seems obvious that I overwrite that file with the one in the archive. However, I don't have a Skyrim.ini. Where does this go? –  oscilatingcretin May 13 '12 at 21:10
    
Your Skyrim .ini should be here -> C:\Users\-name-\Documents\My Games\Skyrim\Skyrim.ini I suggest just reading through the description/front page of the mod and following the instructions. Downloading the .ini is optional I believe –  ChrisGS May 14 '12 at 0:11
    
This worked! Unbelievable. I have spent the past few weeks looking for a solution and this one did it for me. I was going to mark your answer sooner, but I couldn't stop playing Skyrim. Thanks, mate. Also, for anyone else who's wondering, I didn't do anything with Skyrim.ini. I just copied SkyrimPrefs.ini to the folder it already existed in, ran the DOS prompt command, and rebooted. Not a single crash. –  oscilatingcretin May 14 '12 at 11:46
    
Good solution but did you found some fix for 64x? –  Leandro May 14 '12 at 16:34
    
I am on x86, so I didn't attempt diagnosing any problems that may occur on x64 systems. –  oscilatingcretin May 14 '12 at 17:18

I had the same problem that you. I've an ASUS GTS450 for video card, and at some point after enter and reenter from cities and buildings, it's become to loose image mapping (for example, a texture is just a empty violet or yellow color). This is happens in any condition and/or video configuration, low or ultra.

After a research I think it's a memory leak, I think the garbage video doesn't work as expected so it's an acumulation of a lot of things (not bugs), just a sample overflow.

Working with 8GB and the following patch that converts the max use of 2GB to 4GB for memory game use, doesn't solve at all the problem but it's a refresh because right now, my game doesn't crash often, just one time every two days.

Patch: http://skyrim.nexusmods.com/downloads/file.php?id=3211

share|improve this answer
    
+1 for research on question –  Leandro May 11 '12 at 14:29
    
I didn't understood your comment. o.O Can you explain for me please? –  Michel May 11 '12 at 19:13
    
I vote up the question for the research and efforts to self solve –  Leandro May 11 '12 at 19:15
    
Applied the patch, but game still crashes. Gonna try the other answerer's solution. If that fails, I am just going to uninstall the game and throw the box out my car window on the way to work tomorrow. –  oscilatingcretin May 13 '12 at 21:12
    
I do not think you get a solution if you can't wait for a non-exist patch. I just save and quicksave everytime :( –  Leandro May 14 '12 at 4:19

Personally, I put about 18 hours into skyrim before it really started acting up. After that, it would just crash to desktop every 5-30 minutes, and/or I would get this glitch where a great deal of the landscape and enemies would turn a violet colour. The first fix I found was the sound tweak, which of course did nothing, but was probably worth doing anyway. Next, I found out I had the ORIGINAL version of skyrim - Not a single patch or upgrade installed. So I D/L'd the latest official patch, which also didn't seem to help much by itself, but combined with the unofficial patch and the bscedit trick from this link http://skyrim.nexusmods.com/downloads/file.php?id=3211, it hasn't crashed in days!! Probably also worth mentioning that I'm not running any mods or dlc's. The only thing now is that after many hours of consecutive playing, the game fouls up anyway, like the mouse cursor won't ever leave the screen, enemies become invisible, etc. But no more crashing! I can report 100% effectiveness in my case for the above mentioned fixes. I am running a Toshiba laptop with 8GB of RAM, and 700GB of harddrive, but only a single core processor, so it kind of evens out with a lower grade of laptop. (Don't be fooled by WalMart sales!!!). Running with high graphics settings.

Thanks for all the help!

share|improve this answer

Things you can try, in order:

  • Control Panel → Sound → Playback tab; select your Default Device; Properties → Advanced → Default Format. Set to 44.1Khz 16-bit.
  • Verify your game files if you're using Steam
  • Update your drivers and DirectX
  • Turn off SLI, crossfire; multiple GPU rendering; anti-aliasing, filtering; V-sync; background software, firewall, antivirus; FFDShow; other monitors;
  • Set the game compatibility level to "Windows Vista SP2"
  • Update your BIOS
share|improve this answer
    
Please don't just provide links in your answers. Links rot –  badp Oct 2 '12 at 11:03
    
    
I cannot imagine a life without v-sync. Without it, I see too many jagged edges and other visual artifacts that make the game pretty much unplayable. Unfortunately, with some games, it introduces mouse lag which also makes the game unplayable. Luckily, there's usually a way to tweak the settings to keep v-sync and eliminate mouse lag. –  oscilatingcretin Feb 19 '13 at 15:59

All the fixes you need are here http://crashfixes.com/fixing-skyrim-crashes-freezes-errors-steam-crash-no-sound-lags-choppy-framerates/

You're welcome!!

share|improve this answer
4  
That's a giant list of problems and possible solutions, which, by itself, is quite unhelpful. Please re-read the question, and tailor the answer to their specific problem. –  Frank Jan 6 '13 at 5:07
    
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  skovacs1 Sep 19 '13 at 13:58

There has to be something other than these compiled checklists of random tweaks that no one ever reports as 100% effective.

I don't know about the other checklists, but the ones listed here are useful (in my experience). You would need to try out different things (i.e. a checklist) to troubleshoot which one is causing the crashes.

From PCgamingwiki.com 'Skyrim - General Crash Advice' article:

  • Make sure that you have the latest official update, or any well known unofficial crash fixes.
  • Check for problems with your graphics driver (outdated, corrupt or buggy drivers can cause major faults).
  • Utilities bundled with some NVIDIA cards (Smartdoctor, GameOSD and Splendid) have been known to cause crashes and performance issues. Try uninstalling these.
  • For Steam versions, verify the game cache (right click the game in your library, choose "Properties", navigate to the "Local Files" tab and choose "Verify integrity of game cache").
  • Deactivate recently installed mods.
  • If you are experiencing crashing after installing a mod with the Nexus Mod Manager, check the plugins.txt file to see if 'skyrim.esp' is listed twice. If so, remove one so there is only a single instance of 'skyrim.esp'
    • Windows XP Location: C:\Documents and Settings\\Local Settings\Application Data\skyrim
    • Windows Vista\7 Location: C:\Users\\AppData\Local\skyrim
  • If experiencing crashing with loading saved games and WETrigger<(xxxxx)> Error OnInit() type errors after installing mods, install the Creation Kit for better compatability
  • If you install Skyrim and run the launcher and it only has the option to install, locate your Skyrim installation directory and find SkyrimLauncher.exe. Right-click the application and open the properties. Go to the 'Compatibility' tab and under 'Privilege Level' check 'Run this program as administrator'. Apply the settings and then run the launcher again.
  • If your PC shuts down during graphically intense scenes, make sure you power supply unit is a high enough wattage to support your graphics card.

Also, it might be the case of the ol' Savegame bloating. Try the Unofficial Skyrim Patch (UKSP). Among its fixes are:

  • NPCs will no longer drop weapons or shields as separate objects, as these are never cleaned up which greatly adds to save bloating and litters the gameworld (the items will still appear to be dropped, but will access the corpse's inventory to be taken and be cleaned up with the corpse if left)
  • Ash Piles, Ghostly Remains, Ice Piles and Wisp Cores will no longer permanently remain and bloat the save file (they will either disappear on exit of the cell or when the cell resets)
  • The torches on sconce activators will no longer duplicate-in-place (also adding slightly to bloat) when their cells respawn; the duplicate(s) would remain when the player picked up the newest torch (note that this fix is not retroactive for existing duplicate torches; simply open the console, click any duplicate torch and enter delete to get rid of it and no new ones will appear)

The Unofficial Skyrim Patch is a comprehensive Skyrim bugfixing mod that could also help solve other potential CTD issues. Full list of its fixes here.

share|improve this answer
1  
Downvoter(s): Mind explaining your downvote, so I would know what was wrong with my answer? This is also so I could address that concern or edit the answer to improve it. –  galacticninja Feb 19 '13 at 3:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.