Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently purchased Empire Earth Gold Edition from GOG.com. Unfortunately, I've yet to be able to actually play it.

System Specs:

  • Make/Model - HP EliteBook 8530p
  • OS - Windows 7 Ultimate x64 SP1
  • CPU - Intel Core 2 Duo P8400 @ 2.3 GHz
  • RAM - 4 GB
  • Video - ATI Mobility Radeon HD 3650
  • Video Driver Version - 8.911.4.1000

Problem:

When running the shortcut, I see the Empire Earth splash screen and then it switches to a full-screen black window with a "spinning circle" cursor for a few seconds. After this, the window minimizes. In the background, I can hear the game's intro and title screen running, but I can't restore the game window no matter what I do.

Troubleshooting:

  • Updated video drivers from HP's website.
  • Installed June 2010 edition of DirectX, as suggested by GOG.com.
  • Attempted Compatibility Mode settings:
    • Windows 2000
    • Disable visual themes
    • Disable desktop composition
    • Run as Administrator
  • Closed background programs:
    • Firefox
    • Thunderbird
    • Pandora
    • TrueCrypt
    • Trillian
    • Some others
  • Run in Virtual Machine
    • VirtualBox 4.1.8
    • Guest Additions installed
    • Single processor
    • 2 GB RAM
    • 128 MB Video RAM
    • Windows XP Pro 32-bit SP3
    • June 2010 edition of DirectX installed
    • Game crashes immediately after splash screen

I'd much rather be able to run the software natively in the host OS, but I'll settle for getting it to work in the VM if it can be done. Is there anything else I should try? I did e-mail GOG.com support, but was wondering if anyone here might have an answer before they can get back to me.

share|improve this question
    
I've just downloaded it from gog.com. I use window 7 Home premium SP1 (64bits) and it works like a charm. My computer is a laptop AMD Athlon II X2 processor P320. The video card is ATI Mobolity Radeon HD 4520 –  Luc M Jun 9 '12 at 5:43
add comment

2 Answers

Try enabling some or all of the following options in Compatibility Settings:

  • Windows XP compatibility mode
  • Run as administrator
  • Disable visual themes
  • Disable display scaling
  • Disable desktop checked

To get to Compatibility Settings, Right-Click the shortcut/program, and Click Properties. Then navigate to the Compatibility tab.

For the record, here are the system requirements for Empire Earth. Your computer should at the very least meet, if not exceed these standards (Although with an old game like Empire Earth, this shouldn't be too hard).

Minimum:

  • CPU: Pentium II 333 or equivalent
  • RAM: 64 MB RAM
  • Video Memory: 4 MB VRAM
  • Hard Drive Space: 450 MB
  • Mouse: Yes
  • Sound Board: Yes
  • DirectX: DirectX v8.0

Recommended

  • CPU: Pentium III 600 or better
  • RAM: 128 MB RAM
  • Video Memory: 32 MB VRAM
  • Hard Drive Space: 450 MB
share|improve this answer
add comment
up vote 1 down vote accepted

I'm not sure what happened, but the problem seems to have mysteriously self-resolved. All of the troubleshooting steps listed above didn't work the first time, but a few days later the game runs fine even without Compatibility Mode. I may have forgotten to reboot somewhere along the way, or something.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.