Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am running a 64bit version of Windows 7 with a 64bit version of the Java Runtime Environment (JRE) and have been wondering for a while why Steam only says that I am running Minecraft at the login screen (I start Minecraft through Steam, Steam says "Darestium is playing non-steam game Minecraft" then as soon as you log in on Minecraft it changes your status back to 'Online')? I know this is not the case when you are running the 32bit version of the JRE (with a 64bit version of Windows 7 - having uninstalled the 64bit JRE and replacing it with the 32bit), does anyone know a work around this? If anyone knows the cause of this problem I would be really interested to what it is, and why Steam's behaviour differs between Java versions.

share|improve this question
    
Consider posting in stackoverflow.com or superuser.com seeing as this is more programming related. –  Lemmings19 May 7 '12 at 13:47
    
Hmm, I believe I'm running the 64-bit JRE at home, yet don't have this problem. I'll double check this evening. –  MBraedley May 7 '12 at 14:15
1  
@Lemming19 Sir, how is this programming related? - it is clearly a gaming related topic - and has nothing to do with programming. –  Darestium May 7 '12 at 22:54
    
@Darestium I am not saying that it is not gaming related or that it should be removed. I am, however, saying that it relates to something a little more specific than just 'gaming' and that posting a copy of the same question elsewhere may yield better answers. You are asking for the cause of the problem, and it is likely that when you start getting into this sort of thing, the cause will be a technical issue, and therefore related to the code of either Minecraft, or Java and how things differ between 32 and 64 bit. And that, sir, is very programming related. –  Lemmings19 May 7 '12 at 23:58
1  
Have a look at the processes (I'd recommend Process Explorer technet.microsoft.com/de-de/sysinternals/bb896653.aspx for that). I guess that Minecraft behaves slightly different when using a 64bit JRE and starts a new process and exits the initial one, thus causing Steam to "loose track" of the game. –  Koraktor May 8 '12 at 6:11
show 4 more comments

1 Answer 1

up vote 6 down vote accepted

Adding Minecraft (Java 64bit) to Steam

  1. Open the command line prompt as an Administrator. Usually, you can find the command prompt in the Accessoires start menu; right-click on it and chose "Run as administrator", accepting any UAC prompt which pops up.
  2. On the command line prompt, make a local symbolic link to the javaw.exe executable by typing in the following:

    mklink %AppData%\minecraftjava.exe %ProgramFiles%\Java\jre7\bin\javaw.exe

    Replace jre7 with jre6 if you still have Java 6 installed instead; replace the whole Java path if you installed it into a different location.

  3. Try out the new executable with the following command:

    %AppData%\minecraftjava.exe -jar %AppData%\.minecraft\minecraft.exe

  4. Open Steam and in the bottom left, click "Add a Game", then "Add a Non-Steam Game"

  5. Click on "Browse" at the bottom
  6. Navigate to wherever "%AppData%" is on your computer (it's usually in C:\Users\Username\AppData\Roaming) and choose "minecraftjava.exe"

    You can verify the location of the %AppData% folder by opening up a Windows Explorer (Windows+E or right-click on the Start button and chose "Explore") and typing it in the location bar at the top of the window.
  7. Click "Add Selected Programs"
  8. Right click on the entry made in your Steam Library and click "Properties"
  9. Set the target as this (on one line, including quotes)

    "C:\Users\Username\AppData\Roaming\minecraftjava.exe" -jar "C:\Users\Username\AppData\Roaming\.minecraft\minecraft.exe"

    Again replace "Username" with your Windows user name.

  10. Click "Close" to save that change.

To set the icon:

  1. Right click it again and click "Properties"
  2. Click "Choose Icon"
  3. Find your Minecraft.exe file ("C:\Users\Username\AppData\Roaming\.minecraft\Minecraft.exe")
  4. Click "Close"
  5. You may have to set the target to what it was set to above again. (After clicking "Close") because for some reason Steam will forget parameters after changing another setting.

Minecraft should now be able to run via Steam, with support for showing your "In Non-Steam Game" status and with the Steam Overlay.

If for whatever reason it does not work, go back into properties and change to target to what it was set to above. When using parameters Steam sometimes forgets this under other circumstances.

share|improve this answer
    
-1 - you should never manipulate things in your system-wide installation directory like that. –  Martin Sojka Aug 7 '12 at 8:05
1  
@MartinSojka Tthat is not a reason to downvote at all. this is not even editting any files. This is like modifying minecraft.jar, you are making a new copy of it and using that instead of the default one. In the future, please read the post before voting. +1 from me –  Joe the Person Aug 7 '12 at 9:03
2  
Duplicating a file is harmless, that's all that's done in the installation directory. –  njallam Aug 7 '12 at 9:03
    
You can run it without the duplicated file, but if you want to add Technic Launcher, it allows it to be done with the same process, as Steam won't allow the same .exe file twice. –  njallam Aug 7 '12 at 9:04
2  
It will need the Java workspace custom set with the "Open in" settings. This is the simplest way to do this. I said earlier, you can just use javaw.exe instead of the duplicated one. Doing so the way I said in the answer allows the same to be done for Technic Launcher, Spoutcraft or anything else Java-based. –  njallam Aug 7 '12 at 9:16
show 8 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.