Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am trying to download Diablo 3 to be ready at the release date, but I have a problem with the Blizzard Downloader. Unfortunately downloading is very slow and there is a yellow message that says "A listening port could not be opened".

Cropped screenshot of the Blizzard downloader

I clicked help and tried to set up port forwarding as explained, but the warning message persists. How can I solve this problem?

share|improve this question
5  
I don't know about that particular message, but just a note: Blizzard uses a P2P file sharing system that most ISP's count as Torrent traffic. Most ISP's in the United States will give these ports very low priority and will throttle your internet connection while downloading. –  Adanion May 7 '12 at 17:59
1  
334 hours left eh? Looks like you won't make the release. :( –  Brian May 7 '12 at 18:02
    
@Adanion He's in Italy where torrent throttling isn't quite as bad –  badp May 7 '12 at 18:12
1  
In theory my current ISP provider (Telecom) does not filter or drastically reduces torrents download. –  Drake May 7 '12 at 19:31
    
Did you try to disable P2P traffic? It should be somewhere under Download Preferences. –  StupidOne May 7 '12 at 19:35
show 5 more comments

6 Answers

According to this you need ports 6881-6999 open for peer to peer traffic. Make sure your computer and local routers have these unblocked (or at least, properly forwarded). Most routers also have a "DMZ" option for computers, which you can temporarily place your computer in for unrestricted access to the internet. Search Google for "[your router name] DMZ" to learn how to enable this.

Unfortunately, these are common bitTorrent ports and your ISP might be throttling or blocking these ports. If you go to View > Connection Info in the downloader you can see where the problem lies. Most likely only the "Direct Connections" are available and no other "peers".

Your best bet in this case would be to copy the client from a friend who has downloaded it, change your internet service provider or use a proxy.

share|improve this answer
8  
I highly advise against using DMZ for your computer unless you absolutely know what you're doing. It presents a high security risk to unprotected computers. –  NickSuperb May 7 '12 at 18:17
1  
@Nick For a limited time period placing yourself in the DMZ is fine. –  Snuffleupagus May 7 '12 at 18:28
2  
There's no point in risk when port forwarding works just fine. –  NickSuperb May 7 '12 at 18:35
2  
@Nick DMZ essentially opens up all ports, IE not having a router between you and the internet. If I'm not mistaken you'd already have to have malicious software on your system (or poorly developed software that opens up vulnerabilities) for anyone to make use of this, in combination with them finding your IP address (whether scanning a range or targetting you) in the brief span of time you have it open. You're at more risk browsing the web in internet explorer. –  Snuffleupagus May 7 '12 at 18:50
3  
LOL this is not a matter of how DMZ works. Its a matter of one option presenting risk and another having zero risk. With respect to the OP I would only offer a risky solution FIRST if there was no other option. There are too many unknowns about the OP's computer and the goal is to give good advice. –  NickSuperb May 7 '12 at 19:23
show 1 more comment

I had this same problem, and while your question asks specifically with how you open ports, which I think the other answers do a good job describing, that didn't actually result in faster download speeds for me, and based on some comments you left it sounds like it didn't work for you either.

The following, however, did work wonders for me:

  1. Open up Internet Explorer (whether it's your main browser or not).
  2. Go to Tools -> Internet Options.
  3. Click on the Connections tab.
  4. Click the Lan settings button.
  5. Uncheck the "Automatically detect settings" checkbox.
  6. Restart your Blizzard Downloader. (possibly unnecessary)

enter image description here enter image description here

After doing this and restarting the downloader, I suddenly went from truly abysmal speeds (like, 100 MB downloaded over 3 hours) to a > 800 KB/s transfer rate. Even with P2P disabled (and thus, I think, not even needing the port forwarding) I was getting these speeds. Everything else I'd tried before this, such as forwarding ports, disabling the firewall, turning off anti-virus, or enabling/disabling P2P had no effect on my actual speeds.

share|improve this answer
    
I love settings that are only available in the browser. I thought there used to be a way to access this without IE, though. I can't find it anymore. –  Frank May 10 '12 at 17:53
    
@fbueckert You can through control Panel> Internet options or direct in the Registry at HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections –  MaskedPlant May 10 '12 at 17:57
    
I tried your suggestion but download is as slow as before, thank you anyway. –  Drake May 10 '12 at 18:31
1  
A friend of mine stumbled upon this answer and went from 5000+ days to complete to downloading at 6 MB/s and will be done in 30 minutes, so many thanks! –  kazzamalla May 11 '12 at 3:11
1  
I LOVE YOU. +1! After this, it changed my speeds from 20kb/s to 2MB/s ! You rock! –  Zero Stack May 15 '12 at 5:26
add comment

Your router is restricting your use of P2P downloading features. You'll need to modify your port forwarding configuration to accommodate this. Until then you're restricted to passive p2p connections.

Check out these Blizzard support pages for help:

It looks like the following ports are required: 1119, 1120, 3724, 4000, 6112, 6113, 6114, and 6881 through 6999

For instructions on port forwarding. http://portforward.com has historically been a good resource

share|improve this answer
    
I followed exactly that guide. With the help of PortForward.com I setup TCP ports 6881 through 6999 forwarded and Battle.net service features TCP 1120, but problem persists. –  Drake May 7 '12 at 19:24
    
See if something here may help. eu.battle.net/support/en/article/… –  NickSuperb May 7 '12 at 19:27
    
@Drake - You missed a couple ports. –  Ramhound May 10 '12 at 11:34
add comment

DISABLE peer-to peer transferring altogether, my download went from 12 hours to 3. Main reason you get about 6x more downloaders then you get uploaders. It is a nice idea but still a waste of connections.

share|improve this answer
    
There's absolutely no point opening ports if you are not going to use P2P downloading. –  kotekzot May 8 '12 at 11:19
add comment

You can find Internet Options through the control panel, this has been true since WinXP at least, and is still true for Vista and Windows 7. No need to launch IE. As another posted, disabling automatic proxy detection somehow for some reason fixed my download rate. Went from 35kb/sec to the proper 1mb/sec (my service cap). No peer-to-peer is enabled.

share|improve this answer
add comment

http://eu.battle.net/support/en/article/firewall-configuration-for-blizzard-games

List of port ranges, including TCP or UDP for configuration of your router. This is the most complete list I have found.

share|improve this answer
    
Welcome to Gaming! Whilst this may answer the question, it would be preferable to quote the essential parts of the answer here, and provide the link for reference. –  Jupotter May 15 '12 at 5:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.