Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

It says my version is out of date and that I can download the patches on the forums so I click the link and it comes up with the downloads available. When I try to download the patch it opens up a window and does nothing. What should I do?

share|improve this question
    
have you bought it on steam, or do you have the dvd? –  TZHX May 13 '12 at 14:39
    
I bought it off Amazon. i didnt download it or anything. I assume it was you who changed tags. thanks. –  mrminecraft3000 May 13 '12 at 14:41

1 Answer 1

up vote 1 down vote accepted

The patches for Trainz 2010 can be found on the official N3V page.

You need to find what version you are currently running, and then download and install patches in sequence to bring your build numbers up. So, if your build is currently 41491 (the original retail release), you'd need to download and run the following files in order:

You should then be able to "autopatch" to v. 46170 from within the initial game screen. Then apply the following patch:

And that should make you up-to-date for Trainz 2010.

The web servers are a bit slow to respond when clicking on these links, but you should be able to click them, then select "save" and run them.

This only works for retail versions of Trainz, or those purchased directly from N3V (Auran). Games purchased on Steam or other digital distribution means are not supported by N3V.

share|improve this answer
    
my build is 42203 so should i download from the 3rd download or what. –  mrminecraft3000 May 13 '12 at 15:10
    
yes, start from the 42203_to_43434 download –  TZHX May 13 '12 at 15:12
    
This could take some time –  mrminecraft3000 May 13 '12 at 15:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.