Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I can make my own server and connect to it with ease, and my friend can do so likewise. However, I would like to join my friends server, but I cannot connect to his server but he can.

If I have my server up and running while I try to connect to his, then I will be joining my own multiserver instead. But if he has his server running and joins mine, then there is no problem. And when I use the direct connect with his VPN IP it just ends up in a connection timed out.

It seems like I can only recognize and join my own server no matter what I do. But my friend has none of these problems. Anyone got some tips?

share|improve this question
2  
sounds like a vpn question, not a minecraft question. –  legacy May 14 '12 at 15:31
    
Or a port-forwarding/firewall issue. –  MBraedley May 14 '12 at 15:36
    
If you can manage a few clicks of the mouse you should probably just Port Foward –  Wijagels Oct 17 '12 at 21:10
    
Can you check that, 1. the firewall is disabled (on your and your friends pc) 2. the web security of your antivirus software is disabled (same) 3. The ports are not blocked (on firewall, if you can't shut it down) and can you please give the name of the vpn system you are using? –  ardaozkal Nov 11 at 22:31

2 Answers 2

If I understood corectily, you are putting the ip of his VPN into the direct connect box of minecraft multyplayer. you must connect to the vpn then put the ip of the server from your friends network into direct connect.

share|improve this answer
    
I am already in the same network group as him on hamachi. And he can use direct connect with my hamachi IP to my server without problems, but I cant join his. –  Viffer May 14 '12 at 18:32
    
firewall might be the problem then, my question is you said VPN ip, sounding like you were putting in the adress of the vpn itself –  legacy May 14 '12 at 19:59

I would recommend using Tunngle over Hamachi. It was designed specifically for tunneling video games, and from personal experience, does a much better job at it than Hamachi.

However, to actually answer your question: it is likely a firewall or adapter-priority issue. Have him turn his Windows firewall off, and make sure Hamachi is set as the highest-priority adapter in Windows.

Alternatively, just host the game outside of Hamachi, and have him forward the correct port on the router.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.