Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

AOE on my windows machine is unable to detect games setup by my peers (Windows 7) on the same network (LAN) or on the internet.

Is there something I should be doing (patch, fix) to join others with Windows 7/Vista?

share|improve this question
Out of curosity, can you view Win7 network shares from your XP machine? – Robb Aug 31 '10 at 21:20
@Robb Yes i can access machines as \\joe-e4600 \\jim etc – Quintin Par Sep 1 '10 at 5:59
I think "Unable to join" with vista/7 has sg to do with directplay 6-8 incompatibility with vista+'s new tcp handling. We never solved this, playing on Gameranger instead. But I'm still definietly interested in the real solution of this problem. – n611x007 Jul 10 '12 at 20:44
@naxa: I have posted a real solution ^^ – ayckoster Aug 8 '12 at 2:44

I can see you've tagged this AOE 2 - we play LAN games of AOE 2 in our office network successfully with a mixed environment of Windows 7/XP machines. We did notice some issues with the colours in AOE on Windows 7 that were related to a clash with the windows theme - you can see the solution for that at:

With the networking, the only issue we saw was that the Windows Firewall blocked outgoing/incoming connections by default and we had to add exclusion rules for it, by clicking 'Unblock' in the dialog that pops up when the game runs. You would need to 'Alt-tab' out of the game to hit 'Unblock'.

Edit: Also, I have seen success disabling extra networks (wireless, lan, hamachi) when you're trying to play. Sometimes, for whatever reason, an unused/enabled lan network keeps you from connecting with your wireless one. Hamachi is great if you're using it but should be disabled when you're not.

share|improve this answer
Hmm, I was having an issue with not being able to "see" the server even if I try to connect to it via the IP. I was on Win7 and the person I was playing with was on XP. Did you have issues other than the firewall? – Tejaswi Yerukalapudi Aug 1 '11 at 2:29
NB you may need to restart AOE 2 after disabling adapters. Also I've had better luck with wired LAN's than wireless... – rogerdpack Sep 16 '13 at 0:10

Game Ranger allows players to connect to certain games with multiplayer issues, such as AOE 2 and its expansion.

share|improve this answer
Hey James, welcome to the site. While I can also vouch for Gameranger, this answer reads more like an advertisement than anything, and ads are considered spam here. Are you associated with this software at all? It's important when posting answers like this to focus just on the objective qualities of the software, as opposed to over-dramatizing its usefulness. – Mana Aug 8 '12 at 13:07

You can if you use a router, go into the settings of the router and check off UPnP and check if your firewall is not blocking Age of Empires 2.

share|improve this answer

Here is a solution that works most of the time.

Step 1: Enable UPnP on your Router. Please look for a way to do this on your particular router software. Here is how you do it for a router with DDWrt software.

enter image description here

Step 2: Open "Services" and set "SSDP Discovery" to "automatic". For this press the windows key and enter services.msc and open the first entry.

enter image description here

Then search for "SSDP Discovery" double click it and set it to "automatic".

enter image description here

enter image description here

Step 3: Make sure you have the same Default Gateway.

We had also issues because some people had different Default Gateways. Open the network connection, select TCP IPv4 and make sure all entries except the IPs match.

enter image description here

Step 4: Play game with TCP IP (the one where you input an IP address)

This solution worked for 4 out of 5 computers in our LAN. We could not attach the last one though.

share|improve this answer

Instead of going through all the trouble you can always install a Windows XP virtual machine, install the IPX drivers and play over IPX.

share|improve this answer

protected by fredley Aug 8 '12 at 13:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.