Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I created my eyefinity group on my desktop to span 6016 x 1080 resolution, but I can only see 1920 x 1080 (as max resolution) in the video settings in Diablo 3. Is it possible to play D3 while in Eyefinity? If so, how?

share|improve this question
I use nVidia but the concept should be the same. Make sure you alter the aspect ratio drop down, it may be hiding the resolution under it. (Can not test this as I am not at home currently) – James May 15 '12 at 16:37
+1 and PLEASE pictures * - * – Michel May 15 '12 at 17:14
I am working on it right now, but I cannot log into the game again due to the North American emergency maintenance. I will post pictures shortly - but its looking possible! – Zero Stack May 15 '12 at 18:23
@MichelAyres I have posted more details as I did get it to work. See pictures below. – Zero Stack May 16 '12 at 1:44
up vote 6 down vote accepted

I have confirmed this is possible by part of Shinrai's answer, but I feel more detail is needed:

  1. Put the video card(s) into eyefinity and create your desktop
  2. Load Diablo 3, click on Options
  3. By default, you will be looking at the video options. Change Display view to Fullscreen Windowed (click to view fullscreen) enter image description here
  4. Notice: Resolution will be grayed out! Do not worry. (click to view fullscreen) enter image description here
  5. Apply, and Accept. This will automatically fill the screen to the size you specified as your eyefinity desktop resolution.
  6. You will now notice that the home screen is rather messed up. I'm sure Blizzard will patch this at a later time. (see picture directly below for IRL Sorry for poor quality) enter image description here Here is the screenshot(click to view fullscreen): enter image description here
  7. Login, and select your player. The displayed gameplay will work perfectly (see picture directly below for IRL Sorry for poor quality) enter image description here

Here is an in-game screenshot (click to view fullscreen): enter image description here

    (ATI CCC version 12.3)
share|improve this answer
+1 for the Futurama poster. – Brant May 16 '12 at 1:46
And yes... my coffee DID turn into a diet coke. – Zero Stack May 16 '12 at 1:57
Great answer that I'm just now seeing; all my experience with Eyefinity is work-related, and I couldn't throw D3 on a system at the office just to test this myself. Glad to see it works well! – Shinrai May 24 '12 at 15:00
Any reason for the down vote? – Zero Stack Aug 23 '12 at 15:59

I haven't tested this firsthand, but apparently in the beta you were able to select the 'fullscreen windowed' mode where it renders in a window without the borders, pseudo-fullscreen) to support nonstandard resolutions like this.

Here are a few reports of people doing the same in the retail release.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.