Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to play empire earth on my netbook, with win7 pro 32bit, but it crashes. When I start Empire Earth, the videos are played as usual and when the game starts, it crashes. I've tried different compatibility modes and Admin permissions, but nothing worked. Also I installed the latest patches and the Add On (Age of Konquest), but it didn't work. Any Ideas what I could do?


After all that time and many tries, I assume that it is not possible to run ee-zde on my nb. I guess the problem is related to the intel graphics card. Anyway, I will accept the answer with the most votes to get this to an end.

share|improve this question
Empire Earth is Old? It's fully 3d for crying out loud. (Commenting on original tags) – C. Ross Sep 2 '10 at 12:29
Depends on how you define "old". – Michael K Sep 2 '10 at 13:04
This is why I don't think we should have tags for old/classic games; too subjective, requires too much maintenance, and it's not particularly good as a filter – Mana Sep 2 '10 at 13:41
A solution that almost always does the trick for old games: Use a Virtual Machine. Install the required OS (in your case Windows 98 or XP) and the game. Everything should work just fine. – ayckoster Oct 10 '12 at 12:21
Have you tried buying it from Usually, they get it right. – Iszi Oct 10 '12 at 16:10
up vote 3 down vote accepted

Try this post for tips and other people experiences in getting Empire Earth to run on Win 7. Its seems its a bit hit and miss unfortuantely

share|improve this answer
This did not help me, I already tried to run the game as admin, and there is no other solution there, but thank you for the try. – Michael K Sep 2 '10 at 15:07

Could this be the same type of issue that affects other RTS games?

Try closing Explorer.exe either before running the game, or right after it starts.

Here is a question that is asking about older RTS games:

share|improve this answer
I'm sorry for the late reply, but closing the explorer didn't solve my problem. – Michael K Sep 8 '10 at 17:13

Well I have the solution for this old problem, and actually it isn't quite satisfactory...

If you happen to have an old or new(doesn't matter as long as the resolution is equal to or higher than 1024*786) monitor you could just hook up this monitor to your Netbook with a RGB cable(the blue cable that is normally used to connect a monitor to a computer) then you must set your video output to the monitor only(that means that you will only be able to see your computer screen on the external monitor and that your netbook screen should turn black). Then you start up the game and... problem fixed, you'll be destroying other civilizations in no time^^. In case you don't have an extra monitor you could get one for under 40$, so that is quite cheap^^

Hope this helps(worked out for me:p) (found out I wasn't the first one to bring this up...)

share|improve this answer
This may work, thank you for this idea, but I want to play empire earth on my netbook. Thus I don't want to use an extra monitor. – Michael K Jan 10 '11 at 11:08

The solution to your problem is simple... what you need to do is enable downscaling for your netbook's graphics driver in order to set your screen resolution to 1024x768.

To do this, first of all open "regedit" by going to Start and then Run and typing regedit. This will open the Windows Registry editor.

Next, click edit on the menu bar at the top and then click Search and search for Display1_DownScalingSupported:

enter image description here

Finally, double-click on the property we want and change the value from 0 to 1 and then click Ok. Restart your computer and then change your screen resolution to 1024x768 and you can play Earth Empire!

share|improve this answer
Sorry, answers have to be in english. – Frank Apr 24 '13 at 16:24
meager... I'm giving to you and all the perfect solution, try to use google translator to my explain it very simply. do not be a mediocre more – Miguel Alejandro Cancio Apr 24 '13 at 16:48
Arqade is an English site, I'm afraid. If you want this answer to help others, you're going to need to translate it yourself. An automated translator loses much of the context in the process. – Frank Apr 24 '13 at 16:52
@MiguelAlejandroCancio Jeg fatter ikke hvad du siger, kan du ikke svare på dansk så jeg kan forstå dit svar? – Blem Apr 24 '13 at 17:07
Genia Kalina!!! – Miguel Alejandro Cancio Apr 30 '13 at 17:09

Try this

  • Restart/Shutdown after Extracting/Install
  • Run as admin
  • Change to primary driver (Setting)
  • Choose 2nd option 3D Hardware TNL (Settings)
  • Graphic quality choose the middle of Best quality and Best Graphics (Settings)
  • Change Autosave ,Frequency=20, To keep=1
  • 800x600x16 bit screen (Resolution)
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.