Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

It took my gold & says the transaction is completed, but the item isnt in my stash or the send to stash area. What happened?

share|improve this question
    
Make sure that you've space in your stash. That has happened to me. I do think that you get a message about it though so you might already have tried that. –  Whettingstone May 23 '12 at 4:32

2 Answers 2

Sometimes, especially during peak activity on the Auction House, it can take a few minutes for things to appear in the Completed tab. Occasionally I've had good luck getting things to appear here by entering and then leaving the game.

If it's been more than a half hour or so, you might want to post a bug report in the official Bug Report Forums.

share|improve this answer

This happened to me three times already, so I thought I would add my 2 cents. After every attempt to release the "missing item", what eventually worked was to buy an item of the same type. For me I bought a spear worth 1 million to release the "missing" spear I bought for 22mil

Keen to know if this works for anyone else, or if it was a fluke. The item was missing for almost 3 days until I got this right.

Good luck!

share|improve this answer
2  
That sounds like confirmation bias; sometimes bought items are just delayed. –  Frank Apr 15 '13 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.