Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am playing Saints Row the Third with my friend co-op on PC, using the LAN feature.

When playing and say if my friend is driving, there is extreme rubber banding (where the car/objects rubber band [network lag]). Walking around isn't that noticeable, but it is during driving. Both PCs are connected to the router via an ethernet.

We are both on the same network under 1 router. How can we fix this?

There is no firewall running on either PC. My connection is fine, I can get ~2Mbps download on Steam. Or I can copy files over the LAN at Megs a second as well.

I put in a support ticket with the developers, but they're just telling me to update my video card drivers...

This does not happen in any other games played over LAN. Pinging the two PCs results in 0% loss and <1ms response time.

share|improve this question
    
Im suprised this is the case on an LAN network. Try unblocking the ports. –  Doomsknight May 23 '12 at 14:45
    
No ports are blocked on the PCs. –  Zeno May 23 '12 at 23:02
    
Try pinging each other PCs and see if there's any packet loss, might be a problem with the cable. If you're able to connect, then there isn't any problem with the ports. –  kotekzot May 26 '12 at 21:12
    
@kotekzot Yeah made sure of that already. 0% loss and <1ms responses. –  Zeno May 26 '12 at 21:19
2  
I just picked this game up recently and am seeing similar problems. I looked around and apparently it's a known issue - the netcode in this game is just REALLY lousy. –  Shinrai Nov 26 '12 at 1:36
show 1 more comment

1 Answer 1

This is a well known issue of the game since its release. See here: http://www.saintsrow.com/community/go/thread/view/136781/28692595/Lag_while_in_co-op_lan

The problem is not in your hardware, system or network. The problem is in the game engine. But neither the game developer - Volition, nor THQ -publisher, even commented on the issue yet, let alone taking any effort to fix it. (There is a single, one line response from sombody from Volition on the mentioned forum, and that blames the issue, quite nonsensicaly, on somebodys low hardware specs (!?) ).

There are apparently hundreds of people with varying HW and network connections, including me. Including people with flawless lan\net paramaters, people who exceed HW specs for this game and its co-op. Still having the issue.

This is a state of things well in 2013. Still no real fix (official or unofficial) is known to me :(

There are some hints on the forum on how to make it more bearable. In short:
Try to make the game run with same or as similar as possible frame rate (FPS) on all computers that are connected to one coop session. That can be partially (but tediously) achieved by tweaking ingame - mainly Graphic settings.
E.G. On faster computer set graphic details higher (even ridiculously / needlessly high) to slow the game down. On slow computer lower game resolution and other graphic effects settings. Do so until the game on both computers run with as similar FPS as possible.
IF your net connection is all right, this should reduce (though not remove) the rubber-banding effect, at least while driving cars.

This is what I found it the mentioned forum. I didn't test it myself (because the process is really tiresome and not worth it for me).

The bottom line is: remember this issue and how it was never fixed, before buying next game from either of the above mentioned companies.

share|improve this answer
1  
This doesn't answer how to solve the issue at all. –  Frank May 21 '13 at 20:58
    
There is a link to the forum, with few workarounds that 'partialy' 'fix' the issue for 'some' people. The answer Im affraid is: There is no solution :( Still worth mentioning imho, for whoever will be googling for this. –  Riva May 21 '13 at 21:00
    
If there are partial fixes, please add that to your answer. Everything after the link doesn't help anyone resolve the issue, so it's superlefous. –  Frank May 21 '13 at 21:44
    
Just to remind you all, THQ doesn't exist anymore because it went bankrupt, and Volition will be releasing modding tools for SRIV thanks to their new publisher. –  alexanderpas Aug 9 '13 at 0:52
    
@alexanderpas - Is the modding tools relevant in some way to this Q / A ? -- Plus do you have at least an official announcement from Volition / Koch about it ? Can you share the source ? –  Riva Aug 11 '13 at 12:20
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.