Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have three items that increase my attack speed. One is a one handed weapon. The tooltip reads Increases Attack Speed by 7%. The weapons attack speed is in fact 7% faster than a normal weapon of it's type. But when I dual wield, by other weapon doesn't benefit from it.

I also have an Amulet that reads Attack Speed Increased by 10%. When I equip this Amulet, the attack speed of both of my weapons increases by 10%.

Where things really get strange however, is with my gloves. Those read Increases Attack Speed by 15%. Awesome! Except, when I equip them, my attack speed doesn't increase at all.

What's the deal with Attack Speed affixes? Why do they seem to only work sometimes, and even then, not always for both weapons?

share|improve this question

1 Answer 1

up vote 4 down vote accepted

This is the result of a current bug in the way Diablo III Handles Attack Speed enchants, as of version 1.0.1.9558. Essentially, there are two different enchants that increase attack speed, which work slightly differently.

The first kind, which displays on tooltips as Increases Attack Speed by x, is supposed to only show up on weapons. When this Affix is on a weapon, it increases the attack speed of that weapon, but it does not increase the speed of your other weapon if dual wielding. Most importantly, if this verbiage is found an item other than a weapon, it does nothing at all.

The second kind displays it's tooltip as Attack Speed Increased by x. This affix applies it's modifier globally, and will always work, no matter what item it's on. If this affix is found on a weapon, it will even apply to your other weapon while dual wielding.

This is slated to be fixed in patch 1.0.3.

share|improve this answer
    
Do you know if they have a fix for the first issue ("Increases Attack Speed by x" on non-weapons which does nothing)? Will they remove the affix? Fix it? Reroll those items? –  Wikwocket May 26 '12 at 15:34
1  
Do you have any source for this? Is it really a bug and is it going to be fixed? It might be by design that weapon IAS is different from IAS from other sources... –  bummzack Jun 9 '12 at 8:14
    
@bummzack Given that one variant does something and the other does nothing, there's absolutely some kind of bug involved. I won't pretend to guess at what the design intent between having two different attack speed affixes, though your conjecture is as sound as any - point is, both variants appear on both weapons and armor. One works, one doesn't. –  LessPop_MoreFizz Jun 9 '12 at 10:51
    
@Bummzack And yes, it's going to be fixed, as well as nerfed in some way: see the most recent dev. blog for more details. –  LessPop_MoreFizz Jun 9 '12 at 11:08
    
Yeah, I'm aware of the two different affixes and that one doesn't work as intended. Let's assume that there's only one enchantment, it could still be possible that IAS on weapon only affects the weapon (base-speed) and IAS from armor gets multiplied by that... but I guess we'll see as soon as the patch goes live. –  bummzack Jun 9 '12 at 12:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.