Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have a Multi-Monitor setup with 3 screens using my 2 GTX 580's

I would love to use the Windowed Full Screen video option however when I check this with 1920x1080 it stretches the screen across all 3 monitors.

Normally I would be thrilled, but I happen to think it detracts from the experience and I would rather use the other two screens for something more productive.

I have tried messing around in the NVidia Control Panel to no effect...

share|improve this question
    
So you just want to use the middle screen for your gaming? and not the outer two ( far left and far right monitor)? I am kind of confused what you are looking for –  Zero Stack May 31 '12 at 18:30
    
Exactly! I cant seem to get it with just the middle monitor on game . If in regular full screen, the other 2 just turn black. –  Joshua Dudash May 31 '12 at 18:31
    
Try pressing alt+tab to get back to your desktop and then click on D3 again. This happens with a few of my games too with tri monitors. –  Zero Stack May 31 '12 at 18:32
    
Which mode am I trying this in? Fullscreen? Windowed Fullscreen? I would just use windowed mode, but it looks horrible and I accidently resize the window all the time, plus the bottom half is cut off and the Windows task bar is on top... –  Joshua Dudash May 31 '12 at 18:34
    
Question: Do you have your video card set up right now to display the desktop as one giant desktop? Use Fullscreen with 1920x1080 (if possible). Your left and right monitor should be black now. Hit Alt + tab to get to your desktop. Then click on your D3 again. The far left and far right monitor should be showing your desktop now [ This can be 'finicky' as you might have to do it a few times ] –  Zero Stack May 31 '12 at 18:37
show 2 more comments

1 Answer 1

As I specified above in the comments, if you would like your tri-monitor setup to only be full screen in the center and have your far left & far right monitor viewing the desktop (for multitasking purposes), do the following:

  • Go into settings, Video: Make sure you are in Fullscreen Mode
  • Recommended 1920 x 1080 resolution, but it is up to your hardware and personal preferences for display resolution
  • Be sure to save those settings

Now, if this hasn't happened already, you should notice that your computer has grabbed focus of Diable III. The far left and far right monitors are black - with the center monitor showing your game.

  • Now press Alt + Tab to get focus of your desktop ( this should minimize your game)
  • Click the current running [ & hidden ] game of Diablo III to regain focus of that application
  • This should now have your game in the center screen, with your desktop on your far right and far left monitor

If this does not work on your first try, try again until you gain focus of your game with your desktop on the other two monitors. Your system, by default, will want full focus of the game: hence why it blacks out the other two monitors. From my experience this occurs in many other games today with a multiple monitor setup and Alt + Tab is the easiest way of gaining viewable access to your desktop.

Note: It does not matter if you have your video card setup in eyefinity (or the NVidia equivalent of one giant desktop across 3+ monitors)

share|improve this answer
    
I can not get this to work. I have tried about 20 times now.. Not sure what I am missing so far. –  Joshua Dudash May 31 '12 at 22:26
    
I AM clicking on the Diablo 3 icon on my task bar to go back into Diablo 3, correct? –  Joshua Dudash May 31 '12 at 22:39
    
Thats correct.... I can provide a video if you would like. It shouldnt take that long. But like I said, this can be Finicky –  Zero Stack Jun 1 '12 at 20:42
    
I still cant get it :-( If you would? Def + Rep –  Joshua Dudash Jun 1 '12 at 22:39
    
I can provide a little video on it. Although it may take me some time to do it, and it will be a third person shot of it. –  Zero Stack Jun 4 '12 at 14:41
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.