Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm trying the new features included in Minecraft snapshots and I just discovered that jeb_ is adding adventure mode! Yay, finally!

The goal is to create adventure maps in which the player won't be able to destroy any blocks. To create such a map, the easiest way is to create a world in creative mode with commands activated, create the map and then use the /gamemode 2 command to change the game mode to adventure.

My problem is that it will still allow the player to use the commands when he is in the adventure!

Is there a "command to disable commands"? So that after the game mode changing, the right to perform commands is revoked.

Is there a way to change the game mode without commands? So that the original map is created without command options and then change the mode "from outside".

Important note: Of course, I know there are mods and softwares that can do that, I'm asking if there is a way to do that in Minecraft Vanilla.

share|improve this question

2 Answers 2

No, this is not possible in an un-modded, single-player game. There's certainly nothing you can do to a map file to force constraints on the player playing it.

Given that people have been playing adventure maps for ages without the special mode, trust has worked very effectively up to this point :-)

share|improve this answer
    
Nothing you can do in the general case of tinkering with the software, yes, but there is, to my understanding (I haven't been running the snapshots) an option to disable the commands when you create a world. So in principle, a world can exist where the player is in gamemode 2 and commands are unavailable; it's just that there is no way to create it in-game. Am I wrong? –  Kevin Reid Jun 1 '12 at 12:32

As legacy points out, there is no built-in command to disable commands in the Minecraft snapshots. However, you can use NBTedit to retroactively disable commands when you're ready to release you map.

Simply open your level.dat file in NBTedit and change the value of allowCommands to 0.

NBTedit

share|improve this answer

protected by LessPop_MoreFizz Oct 29 '12 at 17:21

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.