Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've read in various guides and FAQs that Diablo II mercenaries can be resurrected from the NPC who lets you hire them; however, I can't find the option to do so. I'm in Act II and Greiz only offers the options to talk or to hire a new mercenary. What am I missing?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

They can be resurrected by talking to one of the NPC folks in town... for a price.

The higher the level of your mercenary, the more expensive it will be. The maximum cost to resurrect your mercenary is 50,000 gold.

Resurrections can be performed by the following NPCs in their respective acts:

  • Act I: Kashya
  • Act II: Greiz
  • Act III: Asheara
  • Act IV: Tyreal
  • Act V: Qual-Kehk

If you don't see an option to resurrect your mercenary, then you either:

  • Do not currently have a mercenary active (haven't hired one)
  • Your mercenary is active and alive

You can check to see if you have one active if you press O to bring up it's stat/inventory menu.

share|improve this answer
    
My hired mercenary just died, I haven't even relaunched the game, but the option doesn't show up. Pressing "o" when I have a mercenary hired does nothing. –  Gnomees Jun 3 '12 at 19:10
    
@Gnomees Which mercenary did you have? Have you tried going back to the NPC you hired them from? Do you see the Merc's portrait icon on the top left corner? Press "Z" to toggle the portrait iron for your followers and summons. –  Krazer Jun 3 '12 at 21:09
    
Have you patched the game, or playing as the standard install? I think most of the merc enhancements were added in a later patch. –  dlanod Jun 3 '12 at 21:17
    
@Krazer — (I'm her roommate.) She was using one of the mercs from Greiz in Act II, the portrait appeared in the corner, and she's patched up to the latest available from Blizzard (1.12?). –  Ben Blank Jun 4 '12 at 22:55
2  
@Krazer I tried logging into Battle.net and it said it couldn't identify my version. So, I reinstalled, then connected to Battle.net as Administrator; it patched up and everything's working fine now. Thank you! –  Gnomees Jun 5 '12 at 22:26
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.