Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My roommates and I like to play Diablo III and World of Warcraft at the same time, but we experience frequent disconnects. If one of the machines is in the DMZ on the router it doesn't disconnect when the other two do. I've turned the router firewall off and this does nothing to help. Any ideas? Can I just forward all the appropriate ports to ALL of the computers?

If I plug straight into the modem I do not experience disconnects.

Router model: FR-300RTR (rebranded d-link)

Router firmware: DD-WRT c24-sp2

Router firewall: off

UPnP: on

dmz: off

manual port forwarding: off

All machines are running windows 7

share|improve this question
    
Have you tried connecting just one computer to the ISP modem? Does it still disconnect then? –  Sorean Jun 5 '12 at 15:49
    
I have tried that and I do not disconnect. –  Jake Jun 5 '12 at 16:57
    
Besides the router, you could also be having issues related to ISP and/or the modem used to connect to it - can you include that info as well? –  Alok Jun 5 '12 at 17:17
    
I use ATT dsl 3mbit connection. I don't have the modem number on me. What information do you need specifically? Model number for the modem and what for the ISP? I've got a second modem now that I can give a trial if I need to do so. –  Jake Jun 5 '12 at 17:31
    
So if you do not disconnect from being directly plugged into the modem, have you tried replacing the ethernet cable between the modem and the router? It could be a bad cable causing the issue. –  Sorean Jun 5 '12 at 17:57

3 Answers 3

You absolutely don't need port forwarding. Port forwarding is only necessary if you host a (game) server behind your router/firewall which is not the case, neither with Diablo III nor with World of Warcraft. In both games all game sessions are hosted on Blizzard's servers.

The following router setup should work no matter how many people are playing World of Warcraft or Diablo III behind the router:

  1. Don't use the DMZ (quite a security risk - if necessary, use port forwarding instead)

  2. Disable your router firewall since you most probably don't need it. Outgoing traffic shouldn't be blocked and incoming traffic which is not initiated by yourself will not reach you since you are using a NAT router.

  3. Only enable port forwarding if necessary. This is the case if you want to host some kind of service behind the router where clients from the Internet need to connect to (e.g. a web server). Some older games require port forwarding though (e.g. WarCraft III, StarCraft I) but Diablo III and WoW don't.

  4. Enable UPNP to make port forwarding easier (will be done automatically) but be careful since this can also be a security risk.

In my opinion your frequent disconnects seem to come from a broken router/modem.

share|improve this answer
    
I have disabled my firewall, moved out of the dmz, disabled all my manual port forwarding rules and enabled UPnP. This is the second router I've tried this week. The first one was a generic belkin from walmart. WIth it we would only disconnect at load screens (and only some times). Now we are on a router running dd-wrt firmware. It is on loan until we figure out our network issues. Even with the firewall off we are having problems. If it helps any to know: it doesn't matter which combo of d3/wow we play. 3 on d3 0 on wow or 3 on wow 0 on d3... still disconnects. –  Jake Jun 5 '12 at 15:31
    
Now that my machine is out of the DMZ I disconnect any time the other two do. –  Jake Jun 5 '12 at 15:32
    
Some modems lose track of a tcp session at some point (say 20 minutes.) Without a port forwarding rule, the server can no longer reply to the client until a new TCP session is started. –  Andomar Jun 5 '12 at 16:02
1  
@speakr: A forwarding rule will forward the packet even if the modem forgot about the game connection. This problem is typically caused by a low /proc/sys/net/ipv4/ip_conntrack_max value on cheap routers. This is consistent with the OP's story: a DMZ (global forwarding rule) prevents his game from dropping. –  Andomar Jun 13 '12 at 8:14
    
@Andomar: You are right, I deleted my comment. However, it does not explain why the OP does not get disconnects when using just one computer. Also, creating port forwarding rules as a workaround may be difficult since you don't know which client ports will be used for your connections. And using the DMZ is no solution, in my opinion. –  speakr Jun 13 '12 at 8:55

Can I just forward all the appropriate ports to ALL of the computers?

You can only forward a port to one computer at a time.

Have you tried turning UPNP on? UPNP allows a game to configure its own ports on the modem.

One likely explanation is a broken modem. Ask your ISP to replace it.

share|improve this answer
    
I have tried UPnP. That just automagically creates port forwarding rules right? –  Jake Jun 5 '12 at 15:27

Firebind can test whether your ports are blocked in the outgoing direction.

They have pre-defined tests for both games:

http://www.firebind.com/tests/diablo3

http://www.firebind.com/tests/wow

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.