Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have 2 graphics cards in my laptop (Alienware M11X); the first is the default Intel graphics card, and the second is a high perf Nvidia card.

I would like to play my Steam games with the Nvidia card (namely Half Life 2, Ep1), but it keeps playing with the Intel card. This is what is shown everytime I start the game:

Using intel card

I have tried starting steam.exe with the Nvidia card, but that doesn't change the card the game uses. I have also tried setting the Nvidia card to the default card to use for all programs, but the game still does not use it. Is there a way for me to do this?

share|improve this question

migrated from stackoverflow.com Jun 7 '12 at 14:45

This question came from our site for professional and enthusiast programmers.

7 Answers 7

up vote 15 down vote accepted

I have a similar computer set up, and here is how I make it work:

  1. Go to the NVIDIA Control Panel by right clicking on your desk top and clicking on "NVIDIA Control Panel".

  2. In the default screen that pops up (it should be "manage 3D settings", and the "Program Settings" tab should be automatically selected), under "1. Select a program to customize:" hit the "Add" button.

  3. From here, navigate to the folder where your steam games are located. For me, it is C:\Program Files (x86)\Steam\steamapps\common.

  4. Select the folder for the game you want to use your NVIDIA card for, and find the .exe for that game (it's usually right in the main game folder). Select it and hit open.

  5. Then, under "2. Select the preferred graphics processor for this program:" open the drop-down menu and select "High-performance NVIDIA processor".

  6. Finally, hit apply in the far bottom right corner, and you should be good to go!

When you start the game from Steam, the .exe will be opened, which will now run with your NVIDIA card by default rather than your integrated card. I've noticed that most older games, when started, will use the integrated card by default. The method described above can be used for any .exe file, not just games in your steam library!

share|improve this answer
    
Yes this did it: I couldn't find the '.exe' before so assumed steam was doing some other behind the scenes stuff to start the game or something lol. Once I did this the dialog above didn't even pop up anymore. I also downloaded the optimus test tools and it said the 'hl2.exe' was using the Nvidea card :) –  LynchDev Jun 8 '12 at 14:20

Alienware m11x utilizes Optimus technology which switches between your Intel HD (to safe your battery life) and nVidia (high preformance on demand) GPU. When you start a game, it do (well, should) switch to your nVidia graphic card.

Just in case, I suggest updating your GPU drivers up to date. If you want to be sure Optimus is working as it should, try monitoring your GPU temperature during gameplay or stress test.

share|improve this answer
    
This is the correct answer - Optimus works behind the scenes and because of the way it works, sometimes applications can think it's using the Intel erroneously. You should be fine by default. (And you can always force things in the Nvidia control panel if for some reason it doesn't seem to be working) –  Shinrai Jun 7 '12 at 23:01

I think what is confusing you is just because Steam gives you that pop-up doesn't actually mean that you are using it. On my laptop I get the same message, but if I was actually using the Intel GD Graphics chipset. The game would not be playable as it does not support certain pixel shaders. So in reality you can just ignore the message, as more then likely in your case you are using the dedicated video card.

share|improve this answer
    
Yup. Steam is not a game, it doesn't need to use the good GPU. –  kotekzot Jun 7 '12 at 18:54
    
Any reason for the downvote? –  Halfwarr Jun 7 '12 at 23:46

I have the Alienware M14X, and if I'm not plugged into an AC outlet, and Window 7's power options is not set on "High Performance" then I get this similar error in other games. Make sure that you're plugged in and that the Power Options in Windows is set for High Performance.

Edit: I believe that Henry2626's solution equates to the same thing as mine, but it's a more roundabout way of enabling "High Performance." Another way to enable this without going into Power Options is via the tray where you see the battery/charge icon near the clock. Clicking on this will give you some power options, but if you don't see High Performance, click on "More Power Options" which will take you to same Control Panel area that I originally advised.

share|improve this answer

It's a bug with the ATI card.

It seems that the card becomes unresponsive - so optimus switches out to the intel card.

Usually turning off the Alienware, pulling the power cord, pulling the battery and holding the power button in will resolve the issue.

I have an M17X-R3.

share|improve this answer
2  
The OP doesn't have an ATI card. –  SevenSidedDie Oct 14 '12 at 18:56

This may not answer the question exactly, but could help determine if the nvidia card is being switched to during high load (which is part of what the question is about).

Optimus State Viewer

Using this tool you could be sure about whether the optimus technology is actually working and you may not have to force anything since its for the best. But if you really need the dedicated card to be grinding all the time then you can force it through the nvidia control panel as others have said.

All you have to do is run the tool and then when you think the load is heavy, like in the middle of a huge battle ingame, you alt-tab out of the game and you can clearly see the state of optimus in the tool.

share|improve this answer
1  
How would you use this tool to figure out if the card is being switched to? –  Frank Sep 24 at 19:39
    
All you have to do is run the tool and then when you think the load is heavy, like in the middle of a huge battle ingame, you alt-tab out of the game and you can clearly see the state of optimus in the tool. –  wardha-Web Sep 24 at 20:00
    
I'd recommend adding that to your answer. It's all well and good to recommend a product, but it's usually a good idea to detail how to use it to meet the need when you do. –  Frank Sep 24 at 20:43
    
Thanks for the guidance bro. :D –  wardha-Web Sep 24 at 21:04

This might be a little dumb but... Are you sure your monitor is plugged to the high end card?

I say this because this process was mostly autodetect afterward for me

share|improve this answer
2  
It's a laptop, he doesn't need to plug in a monitor... –  JohnoBoy Jun 7 '12 at 15:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.