Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Binding of Isaac on my Debian machine, when I try to install the .deb installation package with GDebi, I get the error

Error: Dependency is not satisfiable: libgdk-pixbuf2.0-0.

Any ideas on how I could resolve this issue?


enter image description here

If I uninstall "libpcre3 (= 8.02-1.1)", apparently it will cause heaps of other programs to be removed with it.

share|improve this question
um, is this question somehow not gaming related (hence the downvote?) – Darestium Jun 20 '12 at 11:13
Well, as a (now deleted) answer say, it is more suitable on another site (though I won't recommend Ask Ubuntu unless your question is actually about Ubuntu rather than Debian. Ubuntu being a derivitive of Debian rather than the other way round means it would be on topic at Unix & Linux instead) – Private Pansy Jun 20 '12 at 15:45
@YiJiang So, in that case would you recommend that I re-ask this question at the specified sites? – Darestium Jun 21 '12 at 5:11
oh, proprietary software... anyway, try the .tgz version of the game, it might include the libraries it needs. – JasonWoof Jun 21 '12 at 6:54

As mentioned, this is a dependency issue which may be better suited to the AskUbuntu Stack Exchange website or Unix and Linux Stack Exchange website.

Unfortunately, libgdk-pixbuf2 is quite old, and is part of GTK1, which has been discontinued for quite some time. It looks like this was resurrected from an old stable release a few years back, and there has been an experimental package imported into Maverick and Natty (Ubuntu releases) but should be available in the Debian repositories as well.

If you do the following you may find the new package using APT;

sudo aptitude update
sudo aptitude show gdk-pixbuf
sudo aptitude install gdk-pixbuf

If you get a GPG error (signatures couldn't be verified because the public key is not available) then try to get the key as well;

sudo apt-key adv --recv-keys --keyserver 
share|improve this answer
I've tried using the Synapitic package manager to find the packages, variants of the package for ruby show up. I've installed them, with the vain hope that it will make a difference - it didn't. I've also just tried your commands listed above, they show the same packages listed in Synapitic. – Darestium Jun 21 '12 at 5:09
@Darestium That's because Synaptic is powered by aptitude. If you are not finding them using the above then you will either be missing an aptitude source or will need to compile this from scratch yourself (as per nivomi's answer) – kalina Jun 21 '12 at 7:45

This is a dependency issue, meaning you are missing the "libgdk-pixbuf2.0-0" package. Normally your package installer would handle this on its own, but there seems to be a problem with that. You can find the source to compile from at the following URL:

or try installing it via your distribution's package manager.

However, this could be because something that libgdk-pixbuf2.0-0 depends on is missing, which complicates things further.

share|improve this answer
Well in that case, there is a pre-complied deb file for x86 if you scroll down the page. However, that then shows up with a nother dependency: "Error: Dependency is not satisfiable: libglib2.0-0 (>= 2.31.18)" – Darestium Jun 21 '12 at 11:03
Which in turn has another dependency error... – Darestium Jun 21 '12 at 11:05
@Darestium What is the dependency error you get off this package? – kalina Jun 21 '12 at 12:28
@ickleislands I've updated the main post with a screenshot showing all the dependencies. – Darestium Jun 22 '12 at 12:01
@Darestium from the list of dependencies you've updated with I'm going to take a guess this issue is actually being caused by libpcre3-dbg. As a workaround you could manually download and compile a version that fulfils the requirements of libglib2.0-0 (version 8.10 or higher) and try again, but would recommend that you raise this on the Unix and Linux StackExchange site for a more complete and specialised answer to this problem. – kalina Jun 22 '12 at 12:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.