Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

SMAC is overheating my Win7 64-bit, Core Duo 2.0Ghz, 4GB RAM machine and when I check the Task Manager after playing a few minutes (nothing major happens in the game, I just build my base and move the scout around), I see the following: enter image description here

How should I stop this from happening? Is there a patch that counter-acts this? Would a CPU throttler work? Or something else?

I'm using the GOG version which is already supposed to be patched to the highest official version.

share|improve this question
1  
I've been advised this may have something to do with running SMAC on a 64-bit machine, but I haven't verified this myself yet. –  warsong Jun 23 '12 at 19:15
    
Wow that game is as old as dirt. How odd. Spectacular game however. Good choice. –  Ender Jun 23 '12 at 19:42
    
Yeah I did play it when it was first released. Came back for the nostalgia. –  warsong Jun 23 '12 at 20:02
    
Considering that the GOG version doesn't (as of last time I checked) include Alien Crossfire, I don't see how it could be the most recent version. –  Fambida Jun 24 '12 at 3:20
    
It doesn't include AX but from what I've read the problem exists also on AX, even when patched. –  warsong Jun 24 '12 at 9:07

2 Answers 2

up vote 5 down vote accepted

I keep play SMAX till now, and it works fine on my Win7/x64.

  1. Make a clean installation SMAX (or backup an existing copy)
  2. Install SMAX patch, searchable smacp4e
  3. Install Windows Fix, searchable smacxp103fus

As far as I know, all patches are available for SMAC and SMAX.

Then try the following settings in config:

[Alpha Centauri]
DirectDraw=0 ;; important
Video Mode=2560 ;; your screen resolution
ds3d=1
eax=1
FastUnitAnim=0
SmoothUnitAnim=0

[PREFERENCES]
ForceOldVoxelAlgorithm=1 ;; important

The patches above have quite a few of bugs fixed, including operation on fast or non-Intel CPU's, crashes on air-to-air combat (when fighter defend the city against bombers), division by zero when automated units in polar areas, and many others.

It even works like a charm on WQXGA (2560×1600) screen with no crashes on scrolling.

And it does not require any compatibility settings in Windows.

share|improve this answer
    
I eventually gave up and put WXP on a different machine, it works fine now, no high CPU usage. I think there are some weird processor calls being made that worked with WXP but don't work on W7. Anyway it's sorted now. Thanks. I will check this out and if it does behave okay on W7 then I'll accept it. –  warsong Jul 3 '12 at 21:22

The game runs fine in 32-bit Windows XP (with the usual SMAC patches) on the same machine. It's still hard to prove, but I think it has a lot to do with being 32-bit.

My guess is that some CPU calls are being made that W7 64-bit can't handle properly. I don't know how to prove this, but I've seen it mentioned in several forum threads by now, and starting to see some correlation.

I'll update this when I've checked out a few more possibilities.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.