Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My question is similar to but a little different from this one:

I couldn't find anything in the steam / bioshock forums or troubleshooting manuals about this... Neither could I find any log files that Bioshock 2 generates.

I recently got Bioshock 2 via Steam. When starting it from within Steam, the only thing I see is the launcher and the game binary appearing and (about 30s later) disappearing again in Process Explorer.

The strange thing is, that I can start Bioshock 2 from Windows 7's Start menu.

I tried around with admin priviliges, to no avail.

Using Steam's function to Verify the integrity of the game files was a mistake. It apparently restored the files that were updated when installing the patch that was forced on me by the Games For Windows Live framework that Bioshock 2 appears to be glued to. I'm currently trying to recover from this by removing and completely re-downloading the game from steam.

My system is a 64bit Windows 7.

share|improve this question
Good question with plenty of info included. You get an upvote but no answer I'm afraid. – David Sep 15 '10 at 6:27
Well, in fact there isn't even a question in the text, although one understands what is wanted. – StampedeXV Sep 15 '10 at 18:58
@Stampede I modified the title, there you go :-) – foraidt Sep 15 '10 at 19:12
up vote 7 down vote accepted

Apparently, the Steam Community feature conflicts with Microsoft's Games For Windows Live in-game overlay.
I disabled it and it worked.

alt text

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.