Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I use Skype a lot while playing Starcraft 2, and for many people that I've skyped with, their microphones go extra loud when a map/game is loading.

Sometimes the reverb-like sound gets so loud you have to mute your headset.

I would think it might be the hard drive or the graphics card pulling extra power, but I haven't noticed it during times of intense graphics during a game.

share|improve this question
    
Since SC2 has built-in voice chat (which noone uses), it might be that the Blizzard Programmers were lazy and bound the ingame microphone volume to the system volume and/or set the microphone boost in the system instead of using an ingame boost. –  dbemerlin Jul 12 '12 at 9:52
1  
Funny you ask this, my friend just mentioned that yesterday. XD –  Nick122 Jul 12 '12 at 11:18
add comment

1 Answer 1

up vote 5 down vote accepted

This appears to be a bug in SC2 when using a Realtek soundcard.

Here are two threads on battle.net from users experiencing the exact same problem. The issue seems to be that, when Starcraft II first starts up or first loads a map, it sometimes arbitrarily changes your mic volume and mic-boost settings to whatever it feels like. The reason it doesn't last is that Skype is smart enough to reduce the volume again when it detects how loud it is.

Here is an ironically quiet video demonstrating the issue. The thread that video comes from has a potential solution, which seems to work for some but not others:

  • Open your in-game options and go to the Voice tab. Here’s the settings your game uses to interact with the mic.

  • Change the Settings in the Talking section (you’ll need to Enable Talking first if it’s not already): SC2 mic settings

    • Select the correct Input Device (default device will be picked by default).
    • Adjust the microphone volume to whatever you want your mic set at.
    • Uncheck everything (unless you actually use the Voice Chat).

As a side-note, that same thread also has a solution for another annoying problem us skyper's face: when starting a game during a call, skype (Actually, it's Windows) will sometimes reduce that game's volume.

The solution is to change the setting under control panel --> sound --> communications

sound settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.