Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am currently re-playing The Watchmaker. Unfortunately I have gotten stuck in exactly the same place I did the first time I tried to play it several years ago.

After the sand-trap, Darryl has to pour the bag of blood on the rose, but instead, he drinks(‽) it.

I tried searching for an answer, hoping that there has been a fix or solution since the last time I looked (~2004), but all I can find is the same complaints and speculation.

There do not seem to be any updates or patches for the game and Trecision has long since gone out of business.

The best I can do to work-around it has been to download a savegame which unfortunately was made not only after he pours the blood, but after a cinematic with a lengthy conversation between Darryl and Jude. I cannot find a savegame that was made from just before he pours the blood. The next best thing I could do was to search for a video of the game from when he pours the blood to after he gets the necklace from Jude, but unfortunately the only one I could find is in Checz. As such, I am at best, missing out on a chunk of the game and an important part of the story; and at worst, unable to play the game at all.

I tried a bunch of different things, but sadly none of which worked:

  • I made a list of every object that the person who made the savegame had and made sure to get all of them myself
  • I made sure to visit Jude before pouring the blood on the rose so that she complains about it being a bad time because of a situation
  • I have opened the book and read the bookmark (in fact I did all of these things with both Darryl and Victoria just to be sure)
  • I tried having each of Darryl and Victoria be the one to get scolded by Greta
  • I tried disabling all of the acceleration options and using the lowest resolution in the game's setup program
  • I tried removing the speech files that are installed separately
  • I tried examining the data files to see if there is a way to find the bug and fix it, but there are only two binary files and no scripts
  • I even tried a no-CD patch and loader, but they didn't fix it either

Does anyone have any information on how to get the game to work? At the very least, does anyone know where I can find a savegame that will work, but from before Darryl pours the blood?

share|improve this question
up vote 0 down vote accepted


This time around, I am running the game in 64-bit Windows 7, while the first time I played it several years ago, it was on a 32-bit XP system.

Last week, I was using my 32-bit XP system and decided to see what I could do with the game. I dug out my game CD, but instead of installing it, I simply extract the game files to the drive. I then copied my original savegame files from 2004 and ran it. BAM! To my amazement, Darryl poured the blood on the rose!

Since then, I have done numerous tests on both systems with both of my savegames (from 2004 and recently), in an attempt to narrow down the cause of the bug, and I have noticed several interesting things.

The first thing I noticed was that at the beginning of the game, the current time and room was displayed in the bottom-left corner of the screen whenever you entered a new room. However, at this point in the game, that no longer occurs, yet it does in the Czech video, so it looks like it may be related.

Next, I noticed that with my original 2004 files, there was a purple tooltip when hovering the cursor over the options in the main menu, but there was no such tooltip in my current play-through.

Most usefully, I discovered that when you use the blood on the rose, the game reads a file from the CD and tries to write a file named temp.tmp to the installation directory.

It looks like the bug is a side-effect of the DRM and/or permissions/quota.

If the CD is not in the drive, then Darryl drinks the blood. This happens even if the CD was in when launching the program and removed afterwards. In addition, preventing the write (out of space, permissions, etc.) also causes it. (When playing it in XP, I had installed it on a separate games partition that was usually low on space; now in 7, there’s permissions and VirtualStores, etc.)

Interestingly, I found that the savefiles that did not work, would work under certain circumstances, and savefiles that did work, would not work under other circumstances. Unfortunately this means that getting a savegame file from someone else from just before Darryl pours the blood will not work. However, one saved immediately after he pours it should work.

I also tried using my original options.dat file and also deleting it altogether (it gets recreated). My original options file caused the purple tooltip and deleting the file to have it recreated restored the room/timestamp notice.

So anyone who runs into this/these bug(s) should ensure that:

  • The CD is in the drive and readable (sorry, no-cd patches won’t cut it, and I did not test if using an image will work)
  • You have write permisssions to either the installation directory or your VirtualStore and sufficient space (the file is only ~67KB)
  • Delete your options.dat file (in the Saves directory)
share|improve this answer
I’m not crazy about having to keep a spinning disk in the laptop, but at least it works. Also, I’ll test if ripping the CD to an image and mounting it a VM will work… – Synetech Jul 26 '12 at 19:42

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.