Sign up ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have successfully setup a dedicated L4D2 server on my Linux box. I can manually connect to it with connect <myip>, so I believe I have all the basics setup correctly.

I'm trying to get the server to show up on the "Steam Group Servers" list so that its relatively easy to find and configure through the UI. However, its not showing up there. There are some servers in there from other Steam Groups I'm in, but not this server. (As far as I can tell, the server isn't showing up anywhere in the UI...) (A Steam Group seems like a nice way to make the server "private" without requiring a password.)

Here's my primitive server.cfg. Its got the right "sv_steamgroup" (I've double-checked, but have zeroed it out here.)

hostname "My Home L4D2 Server"
rcon_password "nothisisnotmypassword"

sv_contact ""

sv_cheats 0
sv_clearhinthistory 0 //Clear Server Side Hint History
sv_consistency 1 //Enforce file consistency
sv_pausable 0 //Server not pausable
sv_allow_lobby_connect_only 1 
sv_voiceenable 1
sv_alltalk 0
sv_region 1

sv_steamgroup 000000 // Has valid number in real config file ...
sv_steamgroup_exclusive 1
// sv_steamgroup 0
// sv_password "thisisnotmypassword"
// sv_search_key "myuniquesearchkeyhasbeenreplaced"

sv_lan 0

sv_logsdir "logs"

//sv_pure 2

I've tried starting the server with and without steamuser/steampass. And, I've tried waiting a couple hours for the server to show up in the list. Any suggestions?

share|improve this question
Assuming the server is behind a firewall, have you forwarded the necessary ports (27015 UDP for L4D2)? – DrFish Jul 18 '12 at 11:30
@Bora what difference would it make if it's already connectable via IP? – kotekzot Jul 18 '12 at 13:51
What about sv_region 1? Are all servers in the same region? – DrFish Jul 18 '12 at 14:34
@Bora I'm assuming its just port 27015 I need in the firewall. That works as verified by connect and pingserver from my desktop L4D2 console. However, since my desktop is behind the same firewall as the server, it could be fw problem ... I can telnet <ip> 27015 from a remote host, and the connection is established only if the server is running ... I'll see if I can find a better way to verify this works, though. – P.T. Jul 18 '12 at 17:12
@Bora My server and desktop are in sv_region 1 (US West Coast). I believe most of the other servers I'm seeing in the "Steam Group Servers" are in Europe/Russia (Lots of ".ru" servers?)? Maybe my client has some funky region setting? I'll investigate ... – P.T. Jul 18 '12 at 17:13

1 Answer 1

try using the group's unique ID number this may be what its looking for, and you can find it at the top of the Edit Group Profile page.

if thats not it, try deleting the "//" because that means comment

share|improve this answer
As a general note, I'm noticing you're posting a lot of answers. We prefer answers that show a higher level of quality than a regular forum. Try adding sources to your answers to back up your answer, and spend more effort to ensure your answers actually answer the question. This one, specifically, is a straight guess, so it doesn't actually answer the question. – Frank Mar 28 at 0:02
Nope, no hate. We just have a higher standard here than most of the internet. Just trying to nudge you in the right direction to being a valuable member of the community. – Frank Mar 28 at 0:11
@NightHawk You say "sound like my English teacher" as if it's a bad thing. – Yuuki Mar 28 at 0:11
Who said this question is clear? I didn't. I'm just pointing out that your answer is a sheer, straight up guess. That doesn't qualify as an answer for us here at Arqade. The point of an answer is to solve the problem. This doesn't do that. – Frank Mar 28 at 0:18
@NightHawk If it starts with "try", it's a guess. – Studoku Mar 28 at 1:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.