Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My PC has an awesome GPU (GTX580) but an ageing Core2 quad-core CPU. The game flows smoothly with all graphics options maxed until there is a team fight where up to 10 heroes, and perhaps even with couple of waves of lane creeps, start spamming abilities around. The FPS at times drops as low as <10 which drastically affects my performance.

So I was wondering if there are any rendering options in Heroes of Newerth I can disable to minimize the CPU requirement of the game. Any other tricks to make the game run smoother with a bad CPU would also be appreciated.

share|improve this question
    
HoN is multiplatform, what OS are you running it on? –  Alok Aug 8 '12 at 18:46
    
@Alok: Oh yeah, that's true. I'm running it on Windows, added it to the question. –  Hubro Aug 9 '12 at 11:54
    
are you using a laptop computer? power saving or overheat protection might be the cause –  Uğur Gümüşhan Apr 3 at 20:50

3 Answers 3

First, go to the Nvidia Control Panel and try to disable "Threading Optimization" (might be spelled slightly different; I'm using localized drivers) in the 3D settings. On my GTX 680 this option causes even empty/simple drawings (at least in OpenGL) to sometimes utilize 100% CPU load (at least for one core).

Once this is done (and there aren't any noticeable improvements), try to reduce things your CPU has to handle. Especially for onboard sound cards too high quality sound settings can have a negative impact on performance.

It's been a while since I've tried HoN, so bear with me if the following options aren't there:

  • Try to reduce your vision range, even if it's just by zooming in a bit.
  • Disable UI elements you don't need.
  • Enable level of detail or lower the model (or environment) detail in general. This is drawn by the graphics card, but the CPU still has to upload/modify it from time to time.
  • If you're running on an onboard sound card from Realtek, try to lower the maximum number of sound channels to 16 or 32 and disable hardware acceleration (even if available; the drivers lie about some settings in some cases and emulate missing things in software on the CPU).

More generic suggestions: - Try playing without sound. - If you're running any programs that provide game overlays or similar tools (e.g. Messengers such as ICQ, Trillian, etc.), disable/close them before launching the game. - If possible, use a standalone sound card (PCI or PCI-E) with proper hardware acceleration.

share|improve this answer

shadows and reflections are calculated on cpu, because ray tracing is often done on cpu and hon says that they do it on cpu. anything using the shaders, post process, lights are done on gpu.

your pc may be hitting the 95 degres limit and slowing itself down. you can use a power plan which limits the cpu use, you can try going to power settings and setting cpu upper limit to 99% on windows to avoid turbo mode, also you can use vsync to limit frames and keep heat low so that throttle doesnt happen. your cpu would generate heat because it is old and it is trying to catch up.

for competitive experience, i keep textures, shader quality and model quality high and turn off everything else. (except for the 2x anisotropic filter) and i dont need vsync because i dont go above 60fps. I use opengl mode because directx mode is extremely slow on my pc. I don't know why but i just cant play the game on directx with around 10fps.

share|improve this answer

Guessing you dont have overheated parts, this can be occured by oveclocking, or bad drivers.

Start from turning off shadows, and post-processing. Then reflections\refractions. Try to change video driver from D3DX to OpenGL.

share|improve this answer
4  
I don't think his particular hardware is relevant. This is a general question asking which options are CPU heavy, so anyone should be able to use it as a reference, not just people with the asker's particular setup. –  GnomeSlice Aug 8 '12 at 13:31
    
I have much less powerful CPU, Pentium DualCore E6600 @3.06ghz, and nvidia gts 250. And i never had fps less then 70-80, in heavy team fights it varies in this range. So obviosly its not your CPU –  Avdept Aug 8 '12 at 13:33
2  
@Avdept The question is asking what options can be turned down in order to improve FPS. Answering with "Well, you might be overheating or have bad drivers" doesn't answer the question at all. –  Frank Aug 8 '12 at 13:37
    
Sorry, didnt read question corectly. Start from turning off shadows, and post-processing. THen reflections\refractions. Try to change video driver from D3DX to OpenGL –  Avdept Aug 8 '12 at 13:46
    
@Avdept: Since HoN only uses one CPU core, my Core2 Q6600 Quad @ 2.4ghz will definitively perform worse than your dual core. Also, not sure if I'm interpreting you correctly; are you saying that shadows, post-processing and reflections are CPU heavy rendering options? Because as I stated, my graphics card is state of the art –  Hubro Aug 8 '12 at 13:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.