Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am using the Essentials plugin for my Craftbukkit server. In the config.yml file, under the prevent tag, I set creeper to true in order to prevent Creepers from spawning:

# General physics/behavior modifications
prevent:
  lava-flow: false
  water-flow: false
   ...
  villager-death: false
  # Monsters won't follow players
  # permission essentials.protect.entitytarget.bypass disables this
  entitytarget: false
  # Prevent the spawning of creatures
  spawn:
    creeper: true
    skeleton: false
     ...
    villager: false

However, this does not seem to work, as Creepers are still spawning in my world... Any ideas why?

share|improve this question
    
Have you got EssentialsSpawn.jar? –  fredley Jul 31 '12 at 15:35
    
Yes, and it is loaded successfully. –  kevlar1818 Jul 31 '12 at 15:37
    
Silly question: You have restarted the server after changing the config right? –  fredley Jul 31 '12 at 15:45
    
Yup. I may have fixed it, but I'll need to wait and see when a friend joins my server to trigger mob spawns. –  kevlar1818 Jul 31 '12 at 15:48
    
As a side note, you could be interested in WorldGuard, which allows you to set creeper explosions to not destroy the landscape and buildings (and/or players), globally or in regions defined by you –  Zommuter Jul 31 '12 at 19:09
show 2 more comments

1 Answer 1

up vote 0 down vote accepted

It turns out I had the Mobs plugin installed, and even though I wasn't doing anything with it (vanilla mobs were spawning), it seems to have overrided those settings the Essentials config.yml.

I fixed it by removing Mobs.jar from the plugins directory, reload plugins, then /killall Creepers.

I still plan on using Mobs, but the educational value here is that apparently you can't mix and match Essential's config.yml spawn settings and Mobs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.