Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My LAN server won't let my cousin join me or me join my cousin. It won't show up on the multiplayer screen - it keeps saying "scanning for LAN servers" but it never finds it. I am at his house and we use different computers but it won't connect. How can I fix this?

share|improve this question
2  
Are you using the same username? You can't do that. –  kotekzot Aug 1 '12 at 23:25
    
no im using a different one than him –  Preston Aug 1 '12 at 23:44
1  
Possibly related... gaming.stackexchange.com/questions/47267/… –  Ender Aug 7 '12 at 8:13
    
Another thing is that a while back MC LAN servers stopped working without Minecraft Forge to fix their publishing. Does the LAN server, when you start it, say that the IP is 0.0.0.0: then numbers? Because if it does, that's the problem, and you'll need forge (or, if they fixed it, an update) to make LAN servers work again. –  Tater Tot Sep 22 '13 at 14:11
add comment

5 Answers 5

A few problems that can arise when attempting to connect a game. Note that these suggestions are made to minimize issues, I do not mean to imply you have to meet every condition here for it to work. Also I am assuming a LAN game, since non-LAN games introduce a whole host of other issues to resolve.

  • Lack of connectivity ensure everyone is connected to the home LAN (WiFi or cable), free WiFi or someone else's open WiFi can cause problems.

  • Logins everyone needs to be logged into their own Minecraft account

  • Versions make sure everyone is running the latest version, this includes the server software if you are using it

  • Mods if you are using mods, try it without them to make sure they aren't causing problems, easiest way is to move the folder where your mods are stored somewhere else, including the main jar file

  • Firewalls make sure that your firewall has an exception for the right version of Java, sometimes you can have a few versions installed, which can cause problems. Don't just allow the Minecraft.exe either, since it is just an updater. If your computer is connected to a network that you have told Windows is "public", there are rules in your Windows Firewall that Java set up that will disallow connections from public networks. Try disabling those rules.

  • Router rules can sometimes disallow connecting to other computers on the same network by default, as a security feature. There's no one way to fix this that works for every router, so you'll have to research your particular router and how to check/change its configuration.

  • IP addresses try to have a single IP address for each machine, this means don't connect to the wired and wireless at the same time, it can cause problems

  • Valid IP addresses If you are running Windows, run ipconfig on both machines, and make sure you see 192.168 as the start of the IPv4 address. Also make sure the third digit (usually 0) matches. Google subnet masks if you want to learn how they work. To run ipconfig, you must open the command prompt (cmd) and type in ipconfig, then press enter.

  • Try Direct Connect various problems can prevent automatic finding from working, try typing the address printed when the world was enabled into the Direct Connect link.

Hopefully this covers all of the most common issues.

share|improve this answer
    
192.168.0.0/16 isn't the only private subnet used on lans (just the most common one) there's also 10.0.0.0/8 and 172.16.0.0/12 –  ratchet freak Oct 18 '12 at 19:41
    
yeah I figured but though it might be helpful for some people who did use the other subnets –  ratchet freak Oct 18 '12 at 19:50
add comment

Try using direct connect.

  1. Open up command prompt (type in cmd in the start bar)
  2. type "ipconfig" (without the quotes) and hit enter.
  3. A list of your available network connections should appear. If you are using wireless to connect to your router (I assume you have one, since you are talking about LAN) then find the heading with "Wireless" in it. If you are connected to it using a wire, find the heading that begins with "Local Area Connection".
  4. Find the numbers after "IP Address." This should be similar to with "192.168.x.xxx", where the x's are other numbers.
  5. Hit the Direct Connect button at the bottom in Minecraft, and put the IP Address numbers (dots and all) from the console into the input box. Hit connect. To copy from the console, you'll need to right click in the console and select "Mark", select the numbers, then right click again and hit "copy."

This should work; if you get an error or can't follow (I'm doing this off the top of my head), leave a comment.

share|improve this answer
add comment

Further to @Chaosed0 's answer, I had this problem until I noticed that the IP address given by the server wasn't in my private IP range (192.168.*) but was actually on a subnet associated with VMWare's virtual network adapters. As a quick fix I disabled them and the problem went away - I suppose the LAN server is binding to the first interface it comes across and doesn't care which, but I don't know how to select it (or if you can).

So far as answering the question, check that the IP address given on the server is on the same subnet as the client you're trying to connect from, though I don't know what to do if it's not...

share|improve this answer
    
I had a very similar issue. I have Oracle's VirtualBox installed on my machine. No one in the house could connect via LAN until I disabled it in the Network and Sharing Center on my Windows 7 laptop. Then they could connect again. –  StarPilot May 26 '13 at 23:13
add comment

There are a couple of things I would check.

  • Are they both plugged into the same router? This is the one I would check right away. Ensure that you are somehow not on two different LANs, for example one computer being connected to a modem, and then the other computer is connected to a router or VOIP adapter. If they are both using wireless ensure they are both using the same network. That one computer is not connected to a guest network, and the other the normal network.

  • What network profile are you using? Is it set for home or office, you want it on office to ensure that your computer is discoverable to other computers. To change this if needed

    1. Open Network and Sharing Center by clicking the Start button Picture of the Start button, and then clicking Control Panel. In the search box, type network, and then click Network and Sharing Center.

    2. Next to Connections, click the link for the network connection you want to modify, and then click Properties. Administrator permission required If you're prompted for an administrator password or confirmation, type the password or provide confirmation.

  • Disable any firewall that you have running

share|improve this answer
add comment

Go on the world, make it LAN, then thare will be a server address at the bottom. Tell your cousin to make a server, then put that address in the server address.

share|improve this answer
add comment

protected by Community Aug 3 '12 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.