Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to change time in creative mode of Minecraft? Its so hard to find info because things change so fast and old posts aren't removed. So i apologize if this is a repeat.

share|improve this question
up vote 10 down vote accepted

Yes, if you are running Minecraft 1.3 and above, simply press the T or / key to open the console, type /time set <TIME-OF-DAY>, and press enter.

However, <TIME-OF-DAY> is in ticks. This means the start of the day is 0, nightfall is 12000, and the end of the day is 24000.

Does this not work for you? Here is a possible fix (WINDOWS ONLY):

  1. Download NBTEdit
  2. Make sure Minecraft is CLOSED. Not just on the main menu. CLOSED.
  3. Now you need to get the path to your Minecraft level file, and chances are its location (AppData) is hidden. Do this:
    1. Press the windows key + R and the Run window should come up.
    2. Type in %appdata%.
    3. The Windows Explorer will open, and the folder .minecraft should be near the top. Open it, and then open saves.
    4. Copy the path in the address bar.
  4. Open up NBTEdit. In the menu bar, click File, then click Open. In the address bar, paste the path you copied.
  5. Now, browser to your level's folder. Inside of it, you should find level.dat. Open it into NBTEdit.
  6. If your world has been run on a 1.3 client, it should say Data: 21 entries. Expand that node, and at the very top, chances are it says allowCommands: 0. If it is missing, you must play that world on a 1.3 client. If it says allowCommands: 1, then commands should already work.
  7. Click on allowCommands. Then click on the Pencil in the tool strip. For a value, enter in 1. Now, click File and Save.
  8. That's it! The solution above should now work in your world.

If you know how to make the above solution work in other operating systems, feel free to edit it.

share|improve this answer
I've tried that but nothing happens :( – JimDel Aug 8 '12 at 0:26
Is a button needed to open the console before typing in the command? – murgatroid99 Aug 8 '12 at 0:47
@murgatroid99 Yes, the t key. Added it to the answer. – user3389 Aug 8 '12 at 1:40
I also want to add that you have to enable cheats for this to work Which on creative is automatically enabled but on survival isnt – Serge Bekenkamp Aug 8 '12 at 1:46
@JimDel I think you have to create the world with cheats enabled. When did you create your world? And are you sure you're on 1.3? If your world is too old, there are programs to enable cheats. I'll updated my answer to accommodate. – smoth190 Aug 12 '12 at 20:28

protected by Community Sep 10 '13 at 10:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.