Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

My system specs are as follows:

CPU: AMD Phenom X4 - 2.4GHz GPU: Nvidia GeForce GTX 550 Ti (ASUS, Fermi) RAM: 8GB DDR2 OS: Windows 7 Ultimate, 64-bit

The issue I'm experiencing is that whenever I play Skyrim, after only a few minutes, regardless of my in-game location, my CPU usage skyrockets all the way to 100% and stays there. The fan, of course, also runs at 100% when this happens. When I press Escape and leave the menu open for about 5 seconds, the CPU calms down. It seems the graphic settings are not my issue, as I've lowered my resolution as well as setting the game's settings to 'Low', with no change. I've also uninstalled all of my mods, and unchecked the Dawnguard DLC in the Data Files menu. No change. I also tried uninstalling patches all the way back to 1.1, and still nothing.

What can I do to fix this issue? It's keeping me from playing the game, as I'm 1) annoyed at the noise of the CPU fan when this occurs, 2) concerned about overheating my CPU and causing it damage.

share|improve this question
    
You might want to try and increase some grapical settings especially shadow detail because in most games when on lower settings shadows get processed by your cpu instead of your gpu –  Serge Bekenkamp Aug 10 '12 at 7:40
    
I tried this, as well as taking the side off of my PC tower's case and pulling all of the excess cable (Corsair Enthusiast Series PSUs have a LOT of extra, for me at least) outside of the case. I am not sure which had more effect, but the fan issue is gone. Thanks! –  Cody Aug 10 '12 at 7:45
    
I assume you've done all the standard things. Defrag, Scandisk, cleared temp files, updated graphics and system drivers. Reset the game settings to standard by deleting your ini file. –  DavidYell Aug 10 '12 at 8:00
    
Have you tried to disable antivirus and some other software, that can do some scheduled or background tasks? –  Avdept Aug 10 '12 at 9:34
    
Tried cleaning dust out of the CPU's heatsink/fan? High fan usage is how I can tell mine needs that. –  dlanod Aug 10 '12 at 22:04
add comment

1 Answer

As Serge Bekenkamp already mentioned, the shadows in Skyrim are processed by the CPU, and not the GPU. This is a game engine limitation. Lowering Skyrim's shadow settings will help lessen CPU load.

Other tips that could help CPU performance:

Try cleaning dust out of your PC. See these Super User posts about that:

Also, try the HiAlgoBoost mod. It claims to improve FPS by lowering system resource usage when the player character is in motion. It should help lighten the load for your CPU when playing Skyrim.

HiAlgoBoost dynamically modifies internal rendering resolution in order to increase frame rate, and utilizes various additional approaches to make the game more responsive and smoothly controllable. It does not affect game contents.

HiAlgoBoost features:

  • Significantly improves responsiveness and gameplay experience.
  • Significantly reduces in-game loading times.
  • Increases framerate during character motion by momentarily reducing the resolution.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.