Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I and a friend play minecraft, and with the recent 1.3.1 release we can now open our games to LAN ^_^

Or we can sometimes, sometimes we can't, sometimes we can, it's quite confusing, and we're not sure why it's happening.

See if I open my minecraft game to LAN for people to connect, it says in chat they can connect on IP:port. Sometimes this IP takes the form 5.xx.etc... which is my hamachi IP at the time. When this happens my friend also on Hamachi can connect as expected.

Sometimes however it says 192.168.0.x and he cannot connect, because minecraft is listening on the wrong network adaptor. This also happens on his machine sometimes. We're not sure why it happens sometimes and not others.

How do we fix or control this? We've had the issue on both OS X and Windows 7.

We initially had it trying to connect a macbook air to a PC running windows 7. Apparently Minecraft had picked up the virtualbox network adaptor and had decided to start listening on that, rather than the local LAN. Disabling that adaptor fixed the issue, but disabling the internet will render the Hamachi adaptor unusable.

share|improve this question
2  
Have you tried changing the hamachi adapter priority (in XP, it's network connections --> advanced --> advanced; might be the same under Windows 7, try hitting Alt at the Network connections screen)? Also, disabling the internet adapter, starting the minecraft server, and reenabling the adapter could be an option. Finally, you could try tunngle instead - I've never tried it with Minecraft specifically, but I used to have these sort of problems all the time with many other games (ex. CC:RA2, AoE) under Hamachi, but they all work perfectly under Tunngle. –  BlueRaja - Danny Pflughoeft Aug 10 '12 at 17:00
    
Why are you using hamachi? –  Aidan Mueller Aug 12 '12 at 6:39
    
I see no reference to adaptor priority in Network & Sharing or in the adaptor list. Also I'm using Hamachi because my friends machine is ~2miles away from me. While it's unlikely I can run a CAT6 cable through a city center and under a river, luck would have it there's already a working Internet based connection =p –  Tom J Nowell Aug 12 '12 at 11:55
    
But it does apply to the general case ( Y u no use LAN, y u use inactive virtual adaptor?! ) –  Tom J Nowell Aug 12 '12 at 11:56
1  
@AidanMueller I get the impression you believe this is a firewall or port forwarding issue, it is not. The program is not using the correct network adaptor to listen. For reference I can ping the IPs with no issues with fast responses, I can also run a webserver on both machines, and load webpages from either machine. Contacting the machine is not an issue, making minecraft listen on the right network interface is –  Tom J Nowell Aug 17 '12 at 16:33

1 Answer 1

This problem is likely caused by incorrect network adapter priority.

Danny Plughoeft described the process in XP; to do this in Windows 7, go to Control PanelView network status and tasks under Network and Internet. In the left sidebar, click Change adapter settings, then press ALT+N to bring up the Advanced menu. Finally, choose Advanced Settings.

Then, under the Adapters and Bindings tab, select the Hamachi adapter under Connections and press the up button until it's at the top.

This should make Minecraft (and any other games) always try to use Hamachi whenever it's available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.