Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My biggest pet peeve with Skyrim is that its mouseover detection in menus is shoddy so that sometimes I'll click on one dialogue option but the game will actually select a different one.

Anybody know a workaround for this? This is completely different from the mouse lag issues that other people are having. Also, disabling mouse acceleration doesn't help, so it's not that.

share|improve this question
up vote 10 down vote accepted

The mod, Better Dialogue Controls is an attempt to fix this.


This mod will be most useful for people who like to use both the keyboard and mouse, it fixes issues where the mouse just flat out prevents some keyboard controls from working as expected. If you exclusively use the mouse to scroll and click through dialogues you may not have run into some of these issues. Likewise if you do not move the mouse at all after entering a dialogue. If you move the mouse pointer after entering a dialogue, then you will run into the issues below:

  • A fairly common occurrence is when you leave the mouse pointer somewhere over the menu and you want to use the keyboard controls. If you like to switch to the keyboard navigation now and then, you will run into issues where the mouse pointer just flat out prevents you from scrolling to the top or bottom of the list with the keyboard controls.
  • Another common occurrence is that as you enter the dialogue, you think the first item, next to the pointy bit, is the selected item. However when you press E, you find that the 2nd or 3rd item has been selected. This happens because the mouse pointer takes the focus away from the default option. Often times, I had to move the mouse pointer out of the way when entering the dialogues because of this.


  • The mouse focus now highlights items, but does not make them active. Thus the active item is always at the center of the list (next to the arrow/pointy bit). When you enter a dialogue, the mouse pointer never takes the focus away from the default option.
  • The keyboard controls lets you scroll all the way to the first or last item, no matter if the mouse pointer is hanging over the menu.
  • Scrolling the list with the mousewheel, or up/down controls always maintains the center item as the active one.
  • You can still click off center dialogue items with the mouse, the mouse just won’t affect the menu until you click.
  • The mousewheel scrolling has a smoother transition. It happens because I changed the mousewheel scrolling to work exactly as if you pressed the up/down controls. I didn’t plan to change the mouse wheel scrolling appearance, but I thought it was nice so left it in.


share|improve this answer
Thanks and +1. Always knew the community would come around sooner or later to fix this irksome issue. Do you happen to know if the unofficial skyrim mod has a fix for this or not? – ヴァイシャリ Nov 26 '12 at 13:31
@desaivv I posted about that a few months ago at the USKP thread in the Bethesda forums, and someone mentioned that they don't have a fix for this. Maybe they could implement this mod's fixes, though. According to this mod's author, this mod was made due to the "SkyUI team’s efforts to decompile and clean up the interface code, plus making it available on Github". – galacticninja Nov 26 '12 at 13:34
Ah thanks for all your efforts. Wish I had more votes. :-) – ヴァイシャリ Nov 26 '12 at 13:35
Briefly, the "USKP is still not going to delve into interface related fixes"… – faB Nov 28 '12 at 22:35

This is a problem that happens when what the keyboard navigation has selected is different than what your mouse is pointing at, and the interface apparently reads mouse clicks as Enter instead of targeted clicks.

You can get around this by paying attention to the item highlight: when it won't follow the mouse properly, use the keyboard to adjust the selected item until it agrees with the mouse. It should stay in sync for a while then.

In theory a UI mod could fix this by either replacing the input-handling code or simply disabling keyboard navigation entirely, but I don't know of any offhand.

(I'm writing this from memory—I haven't played Skyrim in ages—so do correct me or downvote if I've got it wrong.)

share|improve this answer
That is exactly what I remember happening :) I just use the keyboard navigation for the dialogue (also since space lets me skip stuff I already know by heart) to avoind this issue altogether. +1 – Assile Aug 10 '12 at 22:12
I haven't played in a while as well, but this is what I ended up doing as well. No mods just used your first solution. +1 – ヴァイシャリ Aug 11 '12 at 2:54
Anybody know what those specific UI mods might be? – ivanatpr Aug 23 '12 at 20:26
SkyUI, while otherwise a must-have mod, does not fix this particular issue for me. – ivanatpr Aug 24 '12 at 22:35
@ivanatpr the SkyMod UI is perfect. I had the same problem and it seems to have gone away after I installed this particular mod. – ヴァイシャリ Aug 27 '12 at 2:49

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.