Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

So my computer is pretty good, it can all but max out Max Payne 3, Mass Effect 3 and plenty of other games. But for some reason, even on the lowest settings (1280*800 resolution with everything set to off or low) Prototype 2 still lags a bunch.

Machine Specs:

Twin HD 5770 in crossfire.
Processor is quad core i5
4GB DDR2 Ram (Maybe it is this?)
SSD hard drive (but its running from a 7200rpm hard drive.)

Any ideas on why I am seeing framerate issues?

share|improve this question
    
This sounds more like a rant than an actual answerable question. Maybe give us some specs of your machine so we can see if there is any factor at all. –  Sorean Aug 14 '12 at 0:25
    
@Sorean My apologies, that's not how I meant it, I have added the specs about (I am not currently at my computer). –  Ben Aug 14 '12 at 1:15
    
What's your operating system? Do you have all the service packs? This sounds like a software issue (such as DirectX running in software mode rather than hardware mode because it can't find the proper version). It could also be that your graphics card is good, but your other hardware is out of date. Out of Mass Effect 3, Max Payne 3, and Prototype 2, it seems to me that Prototype 2 would be the most intensive on the processor. I'm sorry to say, though, I do not know my intel processors. –  smoth190 Aug 14 '12 at 4:52
    
What operating system/Service pack? –  Sorean Aug 14 '12 at 5:11
    
windows 7 SP1, Graphics card Drivers are up to date and the processor is quad core 2.6Ghz all well within the specs required for the game. –  Ben Aug 14 '12 at 5:13
show 3 more comments

4 Answers

up vote 2 down vote accepted

There are some serious issues with the PC port of Prototype 2, from what I can gather.

Most people who have complained about the game's performance have been running on ATI graphics - I'm not sure that 100% of the people having issues are ATI'ers, but from my sample size of probably 20-30 people, I've found most nVidia graphics users to say "it runs great!" and most ATI graphics users to say "Wow, this stinks!"

I went through and collected and collated all the suggested solutions to the problem over here, on my blog but the #1 thing that actually helped me was setting the processor affinity.

If I use Task Manager to force the processor affinity of prototype2.exe to only core 0, the game runs smoothly without issues. If I don't, then I get all sorts of performance issues - sometimes the input lags, often times the frame rate drops like a rock, etc.

If that doesn't work, you can try some of the things that others suggested and had good luck with, but that's where I'd start.

share|improve this answer
add comment

Now, let me tell you the reason why prototype 2 runs terrible. It is because it is terrible. I really do not like to rant, but honestly.. prototype 2 is just a terrible port.

I am running the game with the following specs:

Win7 64bit SP1
i5 2500k @ 3.3GHz
Sapphire Radeon HD7970
16 GB RAM @ 802 MHz

And it's running at ~45 FPS. And ontop of that I even get lagspikes sometimes, where the game drops to about 25 FPS which is ridicilous.

To back this up even more, check out the review from Totalbiscuit, who is also complaining about the performance about the game here.

Sadly, all we can do is pray that they will sent out some patches that improves performance, but don't count on it.

share|improve this answer
1  
45 FPS is 150% the FPS the game was made for :P –  kotekzot Aug 15 '12 at 15:26
    
Yes that's true, but for a PC game it is simply to low. –  Ruddie Aug 15 '12 at 16:47
    
I agree, I think the game is simply written poorly. I dropped everything to the lowest ie. 800*600 res with everything on low or off. And it still gets right down to skipping etc. –  Ben Aug 15 '12 at 23:34
    
Do please mark the answer as accepted ;) –  Ruddie Aug 22 '12 at 10:54
add comment

Some people managed to get much higher FPS when HID is disabled in Device Manager.

share|improve this answer
add comment

Change your settings to switchable graphics and set to high performance. I had the same issue but it run smooth now. Somehow enduro isn't kicking in when playing prototype for that part.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.