Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just got a brand new Sager NP9170 laptop, with Ivy Bridge processor and Radeon 7970m graphics.

The first thing I did to test the machine was to install Steam, and then install the original Portal.

I noticed that there was some serious "tearing" going on and, while it was plenty fast, it really looked ugly whenever I moved the mouse to look around.

My second test was with Portal 2, an obviously much newer game. With Portal 2, which has higher quality graphics to begin with, the experience was very smooth.

So there must be something I can do to get my machine to run Portal 1 (and probably similarly old 3d games) smoothly. Any tips?

share|improve this question
    
I don't think it has to do with the fact that it's an older game. I've got this problem on plenty of new games on my brand new fancy PC as well. It seems to be mostly related to display, and display settings. –  DwarfSlice Aug 14 '12 at 3:28
8  
Have you tried turning vertical sync on? In most Source Engine games, this is under the "advanced" section of the video options. –  agent86 Aug 14 '12 at 3:38

1 Answer 1

up vote 7 down vote accepted

Your tearing problem is most likely related to vsync being off. Your machine being fast shouldn't be a problem with Portal. With some games, you have to force vsync in the drivers, but Portal has a "wait for vsync" option in the video settings. Turn it on and see

share|improve this answer
    
Actually, the machine being fast is the problem. When the FPS is much higher than the monitor's refresh rate (probably 30 or 60), then tearing occurs. However, VSync should fix the problem. I should point out, however, sometimes VSync can cause choppy output. In TF2, I can play it at ~250 FPS, and VSync runs fine. Garrysmod runs at ~200 FPS, but when I enable VSync, the game gets noticeably choppy. I don't know if this is a Source engine glitch or a Garrysmod glitch. –  smoth190 Aug 14 '12 at 4:45
2  
Yes, enabling vsync seems to have cleared up the problem! Thanks! –  Josh Aug 14 '12 at 6:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.