Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently bought Sniper Elite V2 on Steam, which is by the way, a incredible game.

Last week it started to behave weirdly.

Once i first open the game, everything is fine, but after the first "alt-tab", once i bring the game to foreground again, i can see my "windows mouse" on the game screen, and even tho i can use the keyboard in the game without any problems, as soon as i "click" on the screen ( to shoot, for example ) the game window minimizes. I can bring it again to foreground but the same problem keeps hapening over and over until i reopen the game completely.

Any idea of what might be happening here ?

Thanks in advance and sorry about the bad english

share|improve this question
    
This sounds like something is causing Windows to think the game is losing focus. From what I've experienced, this tends to happen on games you play at fullscreen. Have you tried changing it to play in a window? –  Frank Aug 14 '12 at 13:37
    
Yes this is what it looks like. No, i haven't tried windowed mode yet. Fullscreen makes the game alot better to play =/ –  Marcello Grechi Lins Aug 14 '12 at 13:41
1  
If V2 has the option, try using 'Fullscreen (windowed)' ( or equivalent ) mode. It will keep the game windowed, but with certain properties of fullscreen ( I have started to play all of my games with this setting. Useful 2+ monitors. ) –  Phill.Zitt Aug 14 '12 at 16:21
    
Just checked, it does not have the option to play in any other mode than fullscreen. I can only play with the resolution and details –  Marcello Grechi Lins Aug 14 '12 at 22:37

3 Answers 3

up vote 2 down vote accepted

I know it's quite late but I was browsing for solutions to this problem, after receiving the game this week and coming across the same issue.

Seeing this question has no accepted answer and is quite high ranked on google search results I thought I add my 2 cents for what worked for me and maybe it can come in handy for future users as well.


I had the same issue on Windows 7. Every time I tried using my mouse and clicked it minimized the game again. I have 2 monitors so I don't know if that has anything to do with it or not.

After browsing for about 30 minutes and reading up on several possible solution the one that worked for me was to disable desktop composition on the SniperEliteV2.exe

Before anyone asks, I have no idea why this worked or how the windows Aero feature can force a game to minimize that way.

This is how you apply it:

  • Go to the bin folder in the location your game is installed i.e: ..\SteamLibrary\steamapps\common\Sniper Elite V2\bin
  • right-click the SniperEliteV2.exe
  • Select the Compatibility tab
  • Enable disable desktop composition
  • click apply

See screenshot for reference below. (I even applied this change to my executable while the game was running and it worked)

Hope this works for anyone else with the same issue.

enter image description here

share|improve this answer
1  
Late it or not, you got the answer tick :D I simple game up resolving this problem. Perfect timing :D –  Marcello Grechi Lins Jun 7 at 18:55

Taken from here: http://pcgamingwiki.com/wiki/Sniper_Elite_V2#Window_Focus_Issues

Use "Windows XP (SP3)" compatibility mode.

Confirmed working for me using Windows 8 x64 (which has no "disable desktop composition" option, because no Aero).

share|improve this answer

Ctrl+Enter twice will solve it

share|improve this answer
3  
Why will this solve it? Try to give a bit more information, please. –  Frank Mar 20 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.