Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have Super Street Fighter 4 + Arcade Edition DLC and all costumes. My friend has Super Street Fighter 4. We are trying to play against each other, but when I receive an invite, I can't join in his session and when I send an invite, he receives a message that tells that he needs to download something. As far as I know, the problem is not with the costumes DLC, since I already played against a lot of people that does not have alternate costumes. He tried to download and install the Update Kit for SSFIV, but the problem continues. I tried to change the version of my game, but the problem continues too. Do you know what we are doing wrong? Is it impossible to play with two different versions? I'm asking this because in the network battle I have an option to play against SSFIV only. I almost forgot. We are using PS3.

share|improve this question

2 Answers 2

up vote 3 down vote accepted

I solved the problem. My friend SSFIV version is European. His psn user is american. When he downloaded the update kit, he did using the american ps store and the update kit is for the american version of SSFIV and even this package being installed, it does not changed his game (european version). Thinking about this, I said him to create an european psn account, access the european ps store and download the update kit. The european update kit worked as expected and now we are finally able to play.

share|improve this answer
1  
That's great! Then you should mark this answer (your own) as accepted so that people know the question is solved without opening it. –  SevenSidedDie Aug 27 '12 at 17:14
    
I didn't know that I could accept my own answer. Thank you @SevenSidedDie for the tip. I already marked it as accepted. –  davidbuzatto Aug 27 '12 at 17:29
    
There's a delay where the system makes you wait before you can self-accept an answer, so that's understandable. Glad to help! –  SevenSidedDie Aug 27 '12 at 17:30

If you had access to the exact error message, that would likely help narrow down the cause, obviously. But failing that, here are a couple of ideas for things that might be happening:

There are two things that may possibly be happening:

  1. You two are running on different patch versions. (On the Xbox 360, it's not possible to play online without having installed the latest patch, but I don't know whether that's also true for the PS3. If so, this is one thing to check into.)

  2. The lobby host may need to set a specific option in the lobby settings to force "Super Street Fighter IV" (non-AE) mode only. The game definitely has the ability to allow AE and non-AE players to play together, but they will be limited to the SSF4 version of the game. This setting can be changed by the lobby host; I thought that the game was able to auto-detect this and allow clients to switch to the proper mode upon joining the lobby, but it's something worth checking.

    (Note, however, that this capability does not exist on the Arcade Edition disc release; SSF4 "legacy mode" play is only possible if all players are using a "Super Street Fighter IV" disc or Games on Demand version.)

And as you have said, the costumes DLC does not affect this in any way whatsoever.

EDIT: Here are some pictures of the lobby settings that I mentioned in item #2.

enter image description here

Select "SSFIV" on the options menu when you create a new Endless Battle lobby. (I'm not sure whether you could even pick "SSFIV AE" if you didn't have AE installed, but it's worth checking in any case.)

enter image description here

When you create the lobby, the host should see the silver SSFIV logo in the lower-left corner of the screen. (Gold signifies AE, while gold and silver signifies the "both" option.)

If the host is following these steps and can verify that only the silver logo is shown, then I'm afraid I don't have an answer for you. Posting the exact content of the error message that's generated would be the next place I'd go to find an answer.

share|improve this answer
    
Hi. Both of us use the latest patch (1.07, aka ver. 2012). When I create a lobby I'm set to accept only SSFIV users. Yep, I using a SSFIV version with SSIV AE DLC, so my game is a SSFIV copy. There is an option in the main menu where you can "change" the version of your game. I changed to SSFIV too, but the problem continues. –  davidbuzatto Aug 15 '12 at 20:34
    
Sorry to hear you're still having trouble. I'll see if I can take a look at the game tonight to see if I can find anything else that might affect this. –  cloudymusic Aug 15 '12 at 22:17
    
Thank you cloudy. I will wait for your reply. –  davidbuzatto Aug 15 '12 at 22:45
    
Added some photos to my answer just to clarify. If you still aren't able to get this to work, posting the exact error messages that you receive (either when you try to join his game, or vice versa) would be the next place I'd go in order to find a solution. –  cloudymusic Aug 16 '12 at 2:26
    
Additionally, even though you mentioned the SSFIV Update Kit in your question, ensuring that the non-AE player has that kit properly installed and loaded on the active profile (i.e. you're not being notified about it when you start up the game) is another thing you may want to verify, as I believe it's required for cross-version play. –  cloudymusic Aug 16 '12 at 2:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.