Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I like to use loops in my train systems to speed up loading and unloading, with multiple platforms at each station. Each loop feeds into the stations and at the end each train feeds back into that loop. I use entry/exit signals on the entrance and block signals on the entrance of each station. The problem I'm running into on this particular station is that the trains aren't following the entry/exit signals the right way. Take a look at this screen shot:

enter image description here

The train on the far right of the image shouldn't have gone to the left-hand path, which has a red exit signal. It should have gone to the right-hand path which has a green exit signal. Now it is unnecessarily waiting for the other train to finish loading at the platform even though there is an empty one available. What am I doing wrong?

share|improve this question
    
I suspect if you replace your entry/exit pre signals with one way path signals it'll work the way you want. I've never mucked with entry/exit pre signals myself. –  z ' Aug 18 '12 at 15:48
    
@yx, the entry signal acts as an OR gate on each exit signal, so the point is the train waits at the entry signal until one of the platforms opens, otherwise with "normal" signals all the trains will get back logged waiting for the preferred route which is the left-side path. –  lemontwist Aug 18 '12 at 16:02
    
The path signal will also show green as long as there is one path open beyond the light. –  z ' Aug 18 '12 at 19:02

2 Answers 2

up vote 2 down vote accepted

In this case I used @yx's advice and employed one-way path signals. Still not sure why the exit/entry signals weren't working as intended.

share|improve this answer

If you are using YAPF as pathfinder, which is the default nowadays, then I believe you can fix this by making your path signals two-way and enabling yapf.rail_firstred_twoway_eol. The latter can be done permanently by opening your openttd.cfg (see google where to find that file) and change the line:

yapf.rail_firstred_twoway_eol = false

to:

yapf.rail_firstred_twoway_eol = true

You can also enable this setting temporarily, by using the in-game console (open it using your tilde key [`]) and entering:

set yapf.rail_firstred_twoway_eol 1

For more information on this setting, see:

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.