Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I acquired Lego Batman 2 through Steam, and my Windows 7 is in Brazilian Portuguese. The game starts with Portuguese subtitles and there doesn't seem to be a way to change it to English.

Usually there is a menu to change the game language, but I don't see it anywhere on this title.

share|improve this question
1  
I thought lego characters couldn't talk. Man I miss the original Lego Star wars. –  hammythepig Aug 21 '12 at 18:16
    
@hammythepig: No not for this one, there's actual dialogue in this game. –  Jeff Mercado Aug 21 '12 at 23:46
    
they still talk in English... but the subtitles and menus are all in Portuguese, and I can't even turn off the subtitles –  onuryn Aug 22 '12 at 19:42

1 Answer 1

Change language to English

1- Go to regedit

2- Find this location: "HKEY_LOCAL_MACHINE \ SOFTWARE \ Wow6432Node \ Warner Bros. Interactive Entertainment \ LEGOBatman2". If it does not exist, create it. (Note that if the Key "Warner Bros. Interactive Entertainment" already exist, make sure it includes "Bros." instead of "Bros". If not, change it so it contains the period).

3- Find or create the value LanguageVal with the hexadecimal value representing the language your game currently is on. You simply have to change it for the English number, which is 409.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.