Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

For a while now my friend has been unable to play Tribes: Ascend. It shows the updater, he clicks "Play" and then after seeing the splash screen, it shows a black window in the corner of the screen. There is no decoration on the window, just a black square.

It then shows a Crash Dialog which says the following:

SECURE CRT: Invalid parameter detected.

Address = 0x7647b9bc (filename not found) [in C:\Windows\syswow64\KERNELBASE.dll]
Address = 0x4801b1   (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\tribes\binaries\Win32\TribesAscend.exe]
Address = 0x4a88c3   (filename not found) [in C:\Program Files (x86)\Steam\steamapps\common\tribes\binaries\Win32\TribesAscend.exe]

His installation was done via Steam and we have tried validating the game cache and reinstalling Tribes: Ascend. One time we searched for the drive for "tribes" and deleted all that was for Tribes: Ascend. It is however possible that I may have missed something.

His Operating System is Windows 7 (64bit) and his graphics card is a NVidia GeForce GT 440 if that helps at all. This problem is exclusive to this game so I doubt it is a graphics card issue.

In Event Viewer, it says the following on the crash:

Faulting application name: TribesAscend.exe, version: 1.0.1082.1, time stamp: 0x502d8d6f
Faulting module name: KERNELBASE.dll, version: 6.1.7601.17651, time stamp: 0x4e211319
Exception code: 0x00000001
Fault offset: 0x0000b9bc
Faulting process id: 0x1778
Faulting application start time: 0x01cd85d00cb37c7c
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\tribes\binaries\Win32\TribesAscend.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: 6fb53755-f1c3-11e1-9242-14dae903e189
share|improve this question

2 Answers 2

up vote 2 down vote accepted

After a bit of digging around, I discovered that the problem was due to a broken user profile.

Making a new account and copying the data over solved the problem.

share|improve this answer

I would probably look into trying to upgrade the GFX drivers (and any other drivers), jsut to be sure.

http://www.geforce.com/drivers

You could also try to see if the Event Viewer has any errors to report, when launching the game.

The game is built on the Unreal Engine 3, which is the same engine used in Batman: Arkham Asylum & Batman: Arkham City, and all 3 Mass Effect games. Does he have problems with those games?

Edit:

There should be something called: "HiRezGamesDiagAndSupport.exe" which is in the folder where the game is installed. That should be able to diagnose and fix certain things.

Otherwise I have found comments about installing the lastest (stable) nVidia drivers, that should solve some issues.

share|improve this answer
    
Thanks for the response. It is the only Unreal Engine game he owns. When he is next availiable I will look through Event Viewer to help diagnose the error. What I will say is this isn't really much of an answer because it's intention is not to solve, but to diagnose. You may want to move this to the comments. –  njallam Aug 27 '12 at 13:47
    
@njallam Yeah I was unsure wether to make a comment or "answer", so I decided to make an answer which I could edit down the line. –  Holger Aug 28 '12 at 7:42
    
OK, that's fine. Judging by your rep I thought it would be intentional. –  njallam Aug 28 '12 at 7:43
    
See the question. I added more information on the problem. –  njallam Aug 29 '12 at 10:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.