Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Is there a way to play Dark Souls on Windows 8 RTM? Think it crushes because of games for windows live client..
UPD: found the answer here. see Q. Dark Souls crashes and has a reference to XLive.dll, what do?

share|improve this question
    
Does Steam even support Windows 8 yet? –  Frank Aug 28 '12 at 16:47
    
Sleeping Dogs, Portal 2 run well..Think thats not Steam issue. –  0x49D1 Aug 28 '12 at 16:50
    
If it's due to the GFWL client, then it's almost guaranteed a Steam problem; it's not meant to function on Windows 8. Do you have any other Steam games that you know of that use GFWL? Try that, and see if it crashes. If it does, you have your problem. –  Frank Aug 28 '12 at 16:53
    
GTA4. It cant start too.. –  0x49D1 Aug 28 '12 at 18:21

3 Answers 3

up vote 1 down vote accepted

Apparently, Steam installs an incompatible version of Games for Windows. Uninstall "Microsoft Games for Windows – LIVE Redistributable", "Microsoft Games for Windows Marketplace" and then reinstall them from here.

share|improve this answer
    
By the way: here is the answer on my question: forums.steampowered.com/forums/showthread.php?t=2900179 –  0x49D1 Aug 29 '12 at 17:25
    
@0x49D1 Thank you for getting back to us. I hope I found the right bit of information from that post. –  badp Aug 29 '12 at 19:42
    
thanks. Its a bit strange that the question was closed..The problem really exists and may be someone will need the solution too. –  0x49D1 Aug 30 '12 at 6:34
    
@0x49D1 It's mostly the fact you gave us very little to work with :) –  badp Aug 30 '12 at 10:59
    
got 2 '-1' for it :D –  0x49D1 Aug 30 '12 at 12:12

I did the following and this worked for me:

  • I uninstalled Microsoft Games for Windows and installed this one from the Microsoft website
  • Right click on Grand Theft Auto IV in your Steam Library and select 'Properties'
  • Select 'Local Files'
  • Click 'Browse Local Files'
  • Open the GTAIV folder
  • Right click LaunchGTAIV.exe and select 'Run as Administrator'
share|improve this answer

The solution mentioned here helped me greatly, but my own solution was a tiny bit different.

  1. Remove GFWL and marketplace
  2. Run the GFWL installer (download link - downloads from MS/Xbox websites did not work)
  3. Check Windows 7 compatibility mode for DARKSOULS.exe, but not for DATA.exe.
  4. Uncheck all administrator modes and play the game normally through Steam.

Even one of these wrong and either GFWL would not load, or the game would crash before splash screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.