Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I noticed the last few days that my battlefield stats are acting weird. I am working to finish all the premium assignments and have completed all but the wench weilder assignment. I have already completed the 25 shotgun kills multiple times but for some reason it is saying on battlelog and in the game that I still need to complete it. If I use a shotgun in a round and get the 25 kills it will say I have completed that assignment but when I go back to the menu it says I still need to complete it. Also, I just recently complete my engineering service star 3 but I never got the 10000 points or anything saying that I completed it. Is anyone else having this problem?

share|improve this question
    
I got the same problem than you with the assignment "wrench wielder". When I finished the 25 kills with a shotgun, after the game I saw the dog tag "wrench wielder" appear saying that im done with this assignment. But for some unknown reason, when I return to the battlelog it says that I still need the 25 kills with a shotgun... So I tried again different shotguns on different maps, but the problem remains. A week ago when i finished the 3rd soldier service star, I didn't got the 10.000 points right away, but I got them only after 2 or 3 rounds of team deathmatches. The problem seems to be wel –  user31591 Sep 2 '12 at 9:34

1 Answer 1

up vote 1 down vote accepted

Are you sure you never got the 10,000 points? Sometimes it will not show up in-game that you got the service star if you earned another award at the same time.

The reason you haven't completed the shotgun assignment is probably because you weren't using the engineer class when you got the kills. Although it doesn't say it in the assignment, you must get 25 shotgun kills as an engineer to complete.

share|improve this answer
1  
It is a know problem to EA and they are working at fixing it. –  ewein Aug 30 '12 at 3:39
    
This has apparently been fixed in the September patch for Armored Kill, which is live now and will be downloaded next time you boot the game. –  GShenanigan Sep 5 '12 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.