Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I was forced to reinstall my game after the MoP patch came out.

I used to have my preferences set up in a way where I could put autorun on, but when I right-clicked an NPC or an object, click-to-move would kick in and it would walk me to that object and stop me at it.

If I try doing that now with click-to-move enabled, not only will I not turn in the direction where I've clicked, but I also won't stop walking.

This is frustrating me a lot. How can I get the original functionality back?

share|improve this question
    
I think it's an option in your key bindings. Been years since I've played WoW though. –  Fluttershy Sep 3 '12 at 0:18
    
Were you using one mouse button for all of that? –  dlanod Sep 3 '12 at 0:44
add comment

2 Answers

I just tested this out, and with Click to Move on I still can't bind the right mouse button (used for Click to Move) to autorun.

I suspect you had two different settings - Click to Move which works as you described, and Toggle Autorun under Key Bindings, in the Movement Keys section, bound to something else (maybe Middle Mouse, which is bindable).

share|improve this answer
    
Nope, got auto-run set to the tilde key. I tried it on one of mt other computers that had the same settings before, looks like it doesn't work anymore with the MoP patch. –  Nicole Sep 3 '12 at 20:35
add comment

It may be as simple as enabling "click to move" under mouse settings in interface. By default, that command is off. I can still do it. I have toggle autorun on one of my side buttons, and right click turns it off and sends me over to wherever I clicked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.