Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have noticed since the beta to launch they have drastically shortened the distance that characters, mobs and wildlife will appear. To the degree that I was standing on a castle rampart firing my longbow down into attacking centaurs when they all just vanished!

Does anyone know of a way to increase the draw distance or make characters and objects appear when further away from you? I assume probably some exe command switch or ini tweak is in order?

Running nVidia GTX 560Ti with the recommended 304.xx beta drivers.

share|improve this question
    
I'd also like to know the distance that mobs return to neutral. I've spent too many times "re-killing" something that goes passive invincible long enough to heal. Pop-in/Pop-out and the neutral-invincible thing happens to me most during lag (large number of players on screen or just bad internets....) –  esnyder Sep 6 '12 at 19:58
    
@esnyder - I'm not sure that that's related to this question. Why not start your own question asking that? –  SaintWacko Sep 6 '12 at 20:38
    
I believe there is a relationship between the draw distance and the neutral-invincible phase of mobs. As mentioned, during times of reduced performance both the pop-in/out and invincibility happen more often. –  esnyder Sep 6 '12 at 20:54

2 Answers 2

up vote 4 down vote accepted

There is a setting that controls draw distance, it's possible the default for your PC changed between beta and live:

enter image description here

share|improve this answer
    
My LOD distance is set to high and still players and mobs vanish and reappear. I'll have to try and take a video to demonstrate it. –  DavidYell Sep 7 '12 at 8:14
    
@DavidYell: Damn... Can't say I've had issues myself. Have you got up to date graphics drivers? I noticed a huge improvement when I updated mine but it wasn't buggy before either. Might be worth mentioning what graphics card you have too, but at this point I'm not sure what you can do in game to help since this is the setting that is supposed to help this sort of thing. –  Matthew Scharley Sep 7 '12 at 10:26
    
Thanks, I'll do some investigation when I get back home tonight and am at my PC. –  DavidYell Sep 7 '12 at 11:50
    
I have it on High, but it goes up to Ultra –  DavidYell Sep 7 '12 at 17:44
    
@DavidYell: With a GTX 560 you should be able to push everything to max I would imagine. I'm lucky with 2x GTX 470, I didn't notice that LOD and shadows both had an ultra setting, and I get a respectable ~30 fps @ 2560x1440 everywhere I've been. –  Matthew Scharley Sep 7 '12 at 22:45

Are you running teamspeak overlay? if so turn it off :)

share|improve this answer
    
Can you include pictures showing that what you suggest actually helps? I'm not seeing how it could. –  Sadly Not Sep 12 '12 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.