Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am having extreme frame drop issues when recording Minecraft with Fraps. I can record any other game just fine at 60fps and 1080p. Minecraft will normally run at 120+ fps, but when I record, it drops down to ~25. It doesn't matter if I change the recording resolution or what, I keep getting horrible FPS when recording Minecraft.

Here are my PC specs:

  • AMD Phenom II X4 965 OC'd@ 3.68Ghz (Liquid cooled)
  • Radeon HD 6870 CrossfireX (Disabling XFire doesn't help)
  • 16Gb DDR3 RAM @ 1666Mhz (4Gb allocated to MC)
  • 1TB Seagate Barracuda HDD (This is what I record to)
  • 128GB Samsung 830 SSD (This is what my OS and MC run on)

As you can see, my PC is no crappy computer, this is why I'm so frustrated with my Fraps issues. Please Help!

Edit:
Yes I do have optifine.

Double Edit:
So after defragging my disc, I was able to get Fraps up to 40 FPS. I feel like I should be able to get up to 60 though...

share|improve this question
3  
"Minecraft is a pig and doesn't like to share the computer" doesn't help much, I suppose? –  SevenSidedDie Sep 7 '12 at 16:46

1 Answer 1

up vote 1 down vote accepted

The default frame rare that Fraps used to record at is 25, look at your setting and increase that to 40. The problem I suspect is Fraps is max capping your fps. If you increase this the problem will go away.

Fraps does this to save space on the recorded video.

This is a link to the page that shows how to change those settings ensure that your frame rate is not capped at 25 or a lower setting.

share|improve this answer
    
Fraps is set to record at 60 fps. Like I said Fraps works fine for everything else. –  ryansworld10 Sep 8 '12 at 1:24
    
@ryansworld10 try capping Fraps @ 29.7 –  Halfwarr Sep 8 '12 at 4:09
3  
60 fps means your CPU is processing and your HD is trying to store huge amounts of data every second, which could easily be the reason why it's bringing your rig to its knees. Unless you're recording for display on an IMAX screen (in which case you need a computer with film-industry-grade bandwidth between RAM, CPU, and your high-speed RAID), you should limit your framerate to be equal to your target upload framerate, which is probably 29.7 or 25 fps. Minecraft is an unusually-huge CPU, RAM, and HD hog, so it's probably fighting with FRAPs and losing. –  SevenSidedDie Sep 8 '12 at 20:14
    
As great as your rig looks, there is a bottle neck with the Seagate barracuda. Write speeds to a platter-disc device are extremely slow when compared to an SSD. You could try recording to the SSD rather than the Seagate and see if it increases the speed. –  Jasarien Nov 27 '12 at 10:19
    
@Jasarien This question was 2 months ago. Since then I've upgraded to an FX-8320 cpu, an HD 7950 gpu, and the issues seem to have disappeared. Btw, recording enormous files to the SSD is a horrible idea. It would kill the SSD very quickly, not to mention fill it up in minutes. Running Minecraft from the SSD and recording to the HDD works great. –  ryansworld10 Nov 27 '12 at 15:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.