Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Since day 1 of playing Guild Wars 2, I've been plagued by a text-encoding issue in various parts of the UI. It seems that anywhere that certain types of punctuation (bullet points, for example) are intended to appear, other characters are rendered instead, such as Ā, Ą, Ē, Ě, etc.

I first thought this was due to my operating system's region setting at first, but even though I've changed my region setting back to "English (United States)," the issue still persists. I haven't been able to find any discussion about this issue aside from a single buried thread on the official forums with no replies, so I'm not sure how common this behavior is.

Is there a known cause and/or fix for this issue?

Quick technical specs: Windows Vista 64-bit, Core 2 Duo 3.16GHz, 8GB RAM, GeForce GTX 285 1GB

Examples:

enter image description here

enter image description here

enter image description here

enter image description here

share|improve this question
2  
That doesn't look like the right font to me. I would run an image to refresh your game files. gw2.exe -image and leave it overnight, that might solve the issue. –  DavidYell Sep 11 '12 at 8:41
    
@DavidYell: I'll give that a shot tonight and report back. Thanks! –  Panic Bomb Sep 11 '12 at 15:03
    
Yeah, if not there is a -repair option as well apparently :) –  DavidYell Sep 11 '12 at 17:38
add comment

1 Answer

up vote 5 down vote accepted

Solution found! (Sort of.)

First, I tried running gw2.exe -image and -repair, which didn't make any difference.

However, I remembered that I had set "Interface Size" under the graphics options to "Large." Setting the interface size back to Normal resolved the issue. Upon further testing, "Small", "Normal", and "Larger" settings all display the punctuation correctly -- only "Large" seems to produce the issue for some reason.

share|improve this answer
    
Thank you for the discovery. I was about to write to ArenaNet and bash them for not knowing about unicode in the 21st century –  Maciej Hehl Sep 12 '12 at 12:11
    
@MaciejHehl bash them for not implementing it correctly then. –  Serge Bekenkamp Sep 13 '12 at 18:04
    
I'd call that a workaround, not a solution. Did you report this bug to ArenaNet so it can be fixed? Looks like the font used for the Large setting is broken. –  Ingmar Sep 23 '12 at 16:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.