Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I (pre) downloaded and installed Civilization 5 through Steam, on Windows 7. When I start it, Steam asks me if I would like to start:

  • Civilization 5
  • Civilization 5 (DirectX 9)

Then, Civilization "starts" into its menu program and asks me if I would like to start:

  • Civilization 5, DirectX 9 mode
  • Civilization 5, DirectX 10/11 mode, recommended

Can I disable one or both questions, and if so, how?

ie how can I make the game always start in DX10/11 mode without asking me again?

share|improve this question
    
[status-no-repo] on Windows XP. –  alexanderpas Oct 2 '10 at 18:02
    
@alexanderpas Updated (Windows 7) –  WillfulWizard Oct 2 '10 at 18:03
2  
+1 Thanks for asking this. I was about to -- it's been annoying me. –  Feral Chimp Oct 2 '10 at 21:24

4 Answers 4

up vote 14 down vote accepted

Edit

As of the latest Steam / Civilization versions, this problem has been fixed. Launching the game regularly from Steam opens only the Civilization-specific selection window, and right-clicking that menu and creating a specific DirectX-11 link will create a shortcut that shows no DirectX-selection menus.

Original answer:

I'm not sure the "why" is really on-topic here, I just think someone made a mistake. I share your pain.

As for a solution - I've searched online and experimented a bit, and while I could easily bypass the first dialog, I could not bypass the second. To bypass the first dialog, just don't click "play" directly in the Steam game library. Instead, choose one of the following:

  • Run the Civilization V exes directly, found in your installation folder, which should be in <steam folder>\steamapps\common\sid meier's civilization v. It doesn't matter which one you start, unfortunately, they all open that 2nd dialog.
  • A more convenient way for the above method is to ask civ to create a desktop link. In the 2nd dialog, right click and choose "create dx11 desktop shortcut". Keep in mind that despite the name, it will prompt the 2nd dialog.
  • Use Steam's "jump list" to launch the game. Just right-click the steam icon on the taskbar and choose "Civilization V" from the list:

Jump List

This issue is also being actively discussed on the Steam forums, with no resolution at the moment.

share|improve this answer
    
I've updated my question... "Why" was meaning more "what is causing" in the hope of being able to disable it. Either way, your answer is one step closer to a solution. Thanks! –  WillfulWizard Oct 2 '10 at 21:48
    
Best answer I think I can expect until we get a patch addressing this issue, getting rid of the second prompt. –  WillfulWizard Oct 14 '10 at 2:06
2  
I don't know why I've spent the last 5 minutes trying to de-blur Oak's steam game list, but I have. O.o –  Raven Dreamer Oct 14 '10 at 2:22
    
the suggestion to create a shortcut from the launcher doesn't work for me. It works the first time after I create it, but I think that's an illusion. You only get a double question the first time you launch Civ in a given Windows login session. So here's the illusion: I launch Civ and get the double question; on the second question I create the shortcut; then I quit Civ and test out the new shortcut. It works like magic--I only get the second prompt... but that would have been true even without the shortcut. On my next Windows login I'll get a double prompt. Am I missing something? –  Feral Chimp Oct 16 '10 at 14:28

If you do not want a separate desktop icon, here is how to launch Civilization 5 directly from Steam, and default to DirectX 11 with no dialog popup:

In Steam, right click on Civilization 5 and chose "Properties"

Click "Set Launch Options"

In the box, type the following: \dx11 (exactly like that, no quotes, no spaces, just a backslash and dx11)

Press "OK" to exit the launch options dialog

Press "Close" to exit the properties dialog

You are done! Now, when you launch from Steam it will launch the DirectX11 version without asking.

share|improve this answer
    
This is the way to go. Thanks! –  dawmail333 Jun 8 '11 at 2:21

Just go to the game's directory and you will find the .exe file that says civilization V DX11. Right click it and make a shortcut on your desktop.

Mine never asks me which version to start even once. If you prefer to start in DX9 then you can do that with the DX9 .exe file in your games directory as well.

Game on...

share|improve this answer

"C:\Games\Steam\steamapps\common\sid meier's civilization v\CivilizationV_DX11.exe" \dx11

Create a shortcut like the one above. It can also pin to the windows taskbar, unlike most Steam shortcuts. This is the only way I've successfully bypassed the launcher.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.