Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When I had my old laptop, I could run Minecraft quite fine, even with the Amazing Shaders mod. When I got my brand new laptop, I could already imagine the possibilities. 2000+ fps. No lag. I was going to be invincible with my NVIDIA GeForce 630 M.

Or so I thought.

When I opened Minecraft and made a "Test" world in Creative, I was very happy to see how fast things were running until I saw the fps when I hit F3, 93. 93? It didn't look like 93, but I continued to fly around my world relatively smoothly. One and a half minutes later, the "exponential lag" occurred. Two seconds, one frame. Four seconds, one frame. Eight seconds, one frame. This got so bad, it took a while just to exit the game!

Is there any way I can play Minecraft fast ever again? Is it my graphics? CPU? RAM? Please help!

BASIC SYSTEM INFORMATION:

  • Windows 7 64 bit OS
  • Intel Core i7 Quad Core CPU @2.6 GHz
  • nVidia GeForce GT 630M 1 GB
  • 8 GB RAM
share|improve this question
2  
More system information, much more system information! –  Bobby Sep 16 '12 at 9:21
1  
Same advice as Bobby. BTW, are your java install & drivers up to date? –  Lysarion Sep 16 '12 at 11:15
    
Yes drivers are up to date (I got this baby last week) and the latest Java is installed. –  parion Sep 16 '12 at 16:31
2  
@parioscreations But did you update the drivers and Java? "Got it last week" might mean that it's using software from last year for all we know. OEMs are well-known for using out-of-date drivers and software because of scaling problems with keeping everything current. Also, if you have Java 7, uninstall it and downgrade to Java 6. Minecraft and Java 7 often don't get along. –  SevenSidedDie Sep 16 '12 at 17:45
2  
Also make sure that your laptop and especially GPU aren't running in "power saving" mode, which is usually the OEM default setting. It could be throttling the CPU and GPU, on top of potential Java 7 and driver issues. –  SevenSidedDie Sep 16 '12 at 17:49

2 Answers 2

Try Getting the OPtifine mod it adds more options and speeds up your game i have a friend who has terrible internt and when he got this mod his minecraft sped up quite a bit. It is even legal to have on servers.

share|improve this answer

First of all, try different video settings. Such as turning Fancy to Fast if it's on, no smooth lighting and render distance to minimal chunks. Just try scrolling through them and see what the effect is on your performance.

If that does not help, check your ram allocation using F3, and look in the upper-right corner of the screen. If that gets above around 70-80 %, (depending on preference) add more ram to Minecraft. (Remember you need to make sure other programs can still run without Minecraft consuming all the ram so that might be a problem)

You can do this in the profile editor under Java settings (advanced). In JVM Arguments you will see that you can input how much ram you want Minecraft to be running on. In this box you fill in:

"-Xmx2048M -Xms2048M" for 2GB ram

"-Xmx4096M -Xms4096M" for 4GB ram

To add more, add 1024 to the numbers for an extra gigabyte.

eg, 4096 (4GB) + 1024 = 5120 (5GB)

If that does not help, try deleting your .minecraft folder in it's respective location.

Mac: /Library/minecraft

Windows: Press Windows+R, type %appdata& and press Enter. Then locate .minecraft.

But make sure you back the folder up!

Many people have used this technique for similar problems without: eg. Internet connection, so the launcher could not re-download the folder. This is also the folder were world saves and texture-packs are stored so again, back it up first.

if that does not help you need to wait for new vidcard drivers that might solve the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.