Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have the same problem as described here.

I've installed SC2 on two systems, one had this "Insert DVD" problem, the other did not. I deleted all of the files and re-downloaded on the system asking for a DVD and it still asked for the DVD. I tried moving the files out of my home directory as suggested by another user here and it worked. Out of curiosity I tried moving the files to somewhere other than /Applications (I used /Users/Shared) and it still worked. The one thing that comes to mind as a difference between my two systems is that the system where I'm asked for a DVD if the files are in my home directory has Filevault (home directory encryption) turned on. The system where I was not asked for a DVD does not have Filevault enabled. I wonder if the installer is confused by Filevault.

I'm wondering if someone here had the same problem and found a solution to this.

share|improve this question
You may also wish to check Blizzard's SC2 Tech Support knowledge base and/or post this in the Blizzard SC2 Tech Support Forum. – Steven Oct 6 '10 at 16:43
Thanks. You're totally right. I just found it: – znq Oct 6 '10 at 16:51
Does anyone know why FileVault/FV2 isn't supported? I saw speculation on the link here in the comments, but no confirmation (or why other installers don't seem to have problems with FV2...) – Bart Silverstrim Jun 19 '13 at 19:21

I just found the solution here:

You have to either disable FileVault (not recommended) or just move the installer folder to another location, which is not encrypted.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.